Introduction

This workshop for Mac OS X users focuses upon using iPhoto 5, the easy-to-use, all-in-one application for importing, organizing, editing, and sharing digital photos. Topics covered in this workshop include: What’s new in iPhoto 5; Tips on buying a digital camera; importing photos from a digital camera; managing and editing your image collections; creating slideshows; importing music from iTunes into iPhoto 5; exporting images into HTML to a web page with thumbnails; exporting slideshows as QuickTime movies; and pedagogical tips for using digital photos in the college classroom.

Importing Photos from Your Digital Camera

Importing pictures from your digital camera into iPhoto is a very simple task. The good news is that iPhoto does not require any additional drivers or software to get started! Both your computer and your camera must have built-in Universal Serial Bus (USB) ports. To import pictures from your camera, follow the steps below:

1. Plug in your digital camera into the USB port of your Macintosh and turn your camera on.
2. As soon as your camera is connected, iPhoto switches to import mode and your camera appears in the Source list. If nothing happens when you connect your camera, check your camera to see if it’s turned on and set to the correct mode. (For which mode to choose, see the instructions provided with your camera.)
3. Type a roll name for the group of photos you’re importing in the Roll Name field.
4. Type a description for the group of photos in the Description field.
5. If you want the photos to be deleted from your camera as soon as they are imported, select the “Delete items from camera after importing” checkbox. (We suggest that you NOT erase your photos in case something goes wrong in the import... better to erase the photos manually on the digital camera AFTER you are sure you have secured the contents to your hard drive.)
6. Click the Import button.

Wait until all your photos have been transferred into iPhoto or click Stop Import before disconnecting your camera. If your camera has a “sleep” mode, make sure it is disabled or set to a time increment long enough to allow your images to download.

IMPORTANT: Don’t simply disconnect your camera after importing your photos by pulling out the USB plug from your computer port; this may cause damage to your camera. After you finish importing your photos, click the Eject button or drag the camera’s icon from the Finder desktop to the Trash, turn off your camera, and then disconnect it from your computer.
Importing Video Clips from Camera (NEW)

A new feature in iPhoto 5 is the ability to import video clips from any digital still camera that uses QuickTime-supported video formats. To import video clips from your camera into iPhoto, follow the same steps as described above for transferring photos from a digital camera.

The first frame of a video clip is shown in your iPhoto Library with a camera icon and its total running time is displayed on the bottom of its thumbnail. To play a video clip you’ve imported into iPhoto, double-click it. The movie will open in QuickTime Player. You can use the QuickTime controls to play and pause your movie, step through the movie frame by frame, fine-tune the sound, and more.

Importing Photos From Other Sources

You may also want to import photos from other sources (e.g., a photo that was sent to you from a friend in an email that you saved previously to your hard drive). To import photos from other sources, follow the instructions below:

1. Choose File > Add To Library (Command-O).
2. Select the individual photos you want to import, or select an entire folder or disk.
3. Click Import.

Back in iPhoto, click on the Photo Library in the left Source column of iPhoto and scroll through the pictures to find the imported photo(s).

You can also drag individual photos or an entire folder from the Finder into iPhoto's photo viewing area. If you drag a folder, a film roll is created with the folder’s name. If the folder you import contains subfolders, film rolls are created with each subfolder’s name.

Creating a Photo Album

A Photo Album is simply a way to organize your photos according to a specific theme or event; just think of it as a type of folder structure in iPhoto. To create a Photo Album:

1. Select File > New Album (Command-N) or click the Add button near the bottom-left corner of the iPhoto window and choose Album from the New pop-up menu.
2. A dialog box will appear requesting that you enter a name for the album. Type a name for the album (capitalization and spaces ARE allowed) in the text box and click Create.
3. Look to the left Source column in iPhoto and underneath the Photo Library you will see the name of the new album you just created.
4. If you click on the new album, you will see that it is empty. You will need to move the contents that you wish to have in your new album from the iPhoto Library where you imported the photos.
5. To add pictures to the new album, click on the iPhoto Library and click on the images you wish to have in your new album (Shift-click to select multiple photos).
6. Drag the images that you have selected from the iPhoto Library on top of your new album icon and release your mouse (Note: As you drag the photos, a red dot will appear with a number inside; this is the number of images you are currently moving into the album.)
7. Now click on the new album and you will see only the pictures that you inserted there. (Note: The pictures will still remain in the main iPhoto Library but are better organized now into the specific album that you just created.)
8. As an alternative to steps 1-7 above, you can simply create an album from a selection of photos. First, select the photos you want to include in the album, and then choose File > New From Selection > Album. Name the album and click the Create button.
iPhoto will return the image to its original state as it was when it was imported into iPhoto.

Organizing Your Photos

There are several ways you can arrange the photos in your Photo Library or in one of your photo albums.

1. Click on the iPhoto Library and go to the View menu at the top of the iPhoto screen. Select Sort Photos and you will see a number of options from the submenu (i.e., by Film Roll, by Date, by Keyword, by Title, by Rating). By Film Roll displays the photos how they were originally taken on the film roll; by Date displays the photos by the date they were taken; by Keyword arranges your photos alphabetically according to the keyword assigned to them; by Title arranges them by the title you have assigned to them; and by Rating arranges them by the 1-5 star rating that you assigned to them.

2. Although you cannot arrange the iPhoto Library images manually, you can manually arrange the images in your photo albums that you create. Click on any photo album you have created and go to the View menu and select Sort Photos > Manually. Then just click and drag the photos around manually in your photo album in the order that you desire to organize them. (Note: Manual organization of photos is not an option within a Smart Album)

3. The option to view your photos arranged according to Film Roll is only available when you are viewing your images within the iPhoto Library view; it is not a viewing option within an Album or a Smart Album. (Note: If you happen to have a lot of photos and begin to experience slow performance in iPhoto, you can sort your photos by film roll in View > Sort Photos > By Film Roll and then click the triangle next to a film roll in the actual iPhoto Library in order to hide any photos you’re not currently using. To see them again, simple toggle the triangle.)

4. To quickly display only your most recent film rolls, click the Last Rolls icon in the Source list; to display only your most recent photos, click the Last Months icon. If you don’t see the Last Rolls icon in the Source list, choose iPhoto > Preferences, click General at the top of the window, and select the "Show last ___ rolls album" checkbox and selecting the number of rolls you want displayed.

Batch Changes

Sometimes you may need to change the date on a large group of photos. Perhaps they are old photographs you digitally scanned, files imported with the date from when the file was created on your computer (not when the photo was captured) or your digital photos were captured with an incorrect camera date. Maybe you would like to add a general title to all the photos as well, such as “Class Field Trip – April 2004.”

In iPhoto, you can change the title, date or comments on multiple photos at once. Select all the photos you want to change, and go to the menu bar Photos > Batch Change...

From the pull-down menu you can set the Title, Date or Comments.

It’s that simple to make changes to a group of photos. Now with the date and title set, you can easily organize your photos chronologically or by title. (Note: Setting a photo’s title, date, or comments changes it in the iPhoto Library and in ALL Albums, Smart Albums, and Books where it appears.)

iPhoto Image Ratings

Another very useful feature in iPhoto is the ability to apply ratings to your photos. Similar to ratings of songs in iTunes, you can give your photos 1, 2, 3, 4, or 5 stars or none at all.

To rate your photos, first select a photo or group of photos (Shift-select) that you want to give the same rating to (e.g., select a group of photos you wish to assign 5 stars). Then, you can either Control-Click (right-click) the selection and scroll down to My Ratings and select the number of starts you wish to assign, or from the menu bar go to Photos > My Ratings and select the number of starts.

To see the ratings you have assigned photos, make sure that you have View > By Rating turned on.

With your ratings set, you can now arrange your photos by Rating. In the menu bar, select View > Sort Photos > by Rating. You’ve just organized your photos by highest to lowest rating.
Smart Albums

Using the dates, titles or ratings of your photos, you can create Smart Albums. What is a Smart Album? It is a photo album that searches for photos in your library based on the criteria you give, such as Album, Date, Title, My Rating, Keyword, Comments, Filename or Roll. When you create it, the Smart Album finds all the photos meeting your criteria. It also keeps searching for new photos in the future to continuously add to the album. (Note: iPhoto automatically modifies a Smart Album when any photo that matches the album’s settings is added to or removed from your library. It’s a beautiful thing!)

To create a Smart Album, from the menu bar select File > New Smart Album... In the new window, name your Smart Album and select from the pull-down menu on the far left according to your search criteria — Album, Any Text, Date, Title, My Rating, Keyword, Comments, Filename or Roll. To add more than one criterion for the Smart Album, click the + button on the right. You can also delete a criterion with the - button. The figure below illustrates a Smart Album set up with the following criteria: 1) Photos selected from the Album previously created called “Cal Poly Photos”; and 2) My Rating of 5-stars; and 3) Photos taken after the date of February 28, 2005.

When iPhoto creates the Smart Album, it places it in your Source list with a gear symbol on its icon. Any photos in your iPhoto Library that match the settings you chose are added to the album.

Setting iPhoto Preferences

You may wish to change your display preferences in iPhoto. To do this, follow the instructions below:

From the iPhoto menu at the top of the screen, select Preferences...

The Preferences dialog box will appear. Click on the General button to set the General preferences.

1. Under the area labeled Sources: select the numbers you desire for the default Smart Albums that iPhoto includes to be generated according to numbers of months and numbers of rolls. You may also select the preference of a photo count to be shown for each album.

2. Select what happens when a photo is double-clicked: Changes to edit view (choose this option for today’s class), Opens photo in edit window, and Opens photo in: which allows you to have a double-clicked photo open in a selected application such as PhotoShop when you define the application by clicking on the Select Application... button.

3. Where it says, “Rotate” choose the direction for the rotation of your photos (clockwise or counter-clockwise). After Preferences are set, the rotation button icon in the edit window of iPhoto will change to the direction you selected here.
4. Select the email software that you currently use on your computer from the pop-up menu as the Email photos using setting.

5. If you wish to have your computer check for iPhoto updates automatically, select the check mark next to “Check for iPhoto updates automatically.”

Now that you’re finished with setting up the General preferences, click on the Appearance button at the top of this dialog box to set the Appearance preferences.

![Figure 7: Appearance Preferences](image)

1. In the Border: area of this dialog box, make your Appearance choices of Outline and Drop Shadow, and select the color you wish to have in the area labeled Background: (Note: This is referring to the background tint when viewing the Photo Library or individual albums in iPhoto. A darker choice is generally better.)

2. Choose how the photos are organized and aligned in the area labeled Organize View: (i.e., Align photos to grid and/or Place most recent photos at the top).

3. Select the size of the Source Text: (this is the size of the text in the program itself, such as the size of the text for the album names listed in the far left column of the iPhoto Source window.)

Now that you’re finished with setting up the Appearance preferences, click on the Sharing button at the top of this dialog box to set the Sharing preferences.

The Sharing Preferences allow you to share your creations with anyone who shares the same network. Now you can share your photos with your whole family or your Macintosh work colleagues that share the same network. iPhoto offers Rendezvous photo sharing -- the same technology that allows you to share songs and playlists in iTunes; however, instead of music, you can share photos with everyone on the same network. By selecting these preferences, you can share the photos of your entire library or just selected albums. You may also set a password that you can give out to friends on your network so that only a select few individuals can view your photos. (Note: Sharing preferences requires that the firewall port 8770 not be blocked on your computer. To unblock this firewall port, go to System Preferences > Sharing > Firewall)

iPhoto 5 offers one more preference to setup in this dialog box that wasn’t available in iPhoto 4: Keywords. We’ll come back to this preference later in the section where we discuss Keywords. For now, you’re finished setting up your preferences. Click the red close button at the top-left corner of the dialog box to apply these preference settings and close the Preferences dialog box.

### Rotating Images

Occasionally, you may take a picture with your camera held vertically (portrait view) and then the image comes into iPhoto incorrectly. For example, the picture below was taken with the camera held vertically and now it appears to be turned on its side when imported in iPhoto:

![Figure 8: Photo in Need of Rotation](image)

To place the photo in the correct direction, click on the photo to select it and then click on the Rotate button in order to turn the photo at 90-degree angles; keep clicking until it is vertically displayed as you desire. (In this case, because my Preferences were set with a counter-clockwise rotation, I only had to click on the Rotate button once to place the photo into the proper vertical alignment, whereas a clockwise rotation would have required three mouse clicks.)

### Adding Titles & Comments to Photos

You can add titles and comments to any of your photos:

1. Click on the photo album you desire. At the bottom of the Source list, you will see an Information box providing information on the album you clicked upon. If you don’t see the Information box, click on the info button underneath the column containing the photo albums.
2. iPhoto will display information about the album name, the date span of the photos in the album, the number of photos, and the size in bytes.

3. Click on any single photo in the album and then you will see the above information for that particular photo as well as any comments that were assigned to the photo.

Customizing the Organize Toolbar

The organize toolbar is the row of buttons that appears at the bottom of the iPhoto window when the iPhoto library or an album is selected in the Source list. You can customize the organize toolbar by adding or removing buttons that let you perform the most common tasks for sharing your photos.

1. Choose Share > Show in Toolbar and select the buttons you want to appear in the toolbar from the submenu. (A selected item has a check-mark next to it; choose the item again to deselect it.)

2. For the purpose of this tutorial, please select all of the items (one-by-one) in this list so that they have a checkmark next to them. You will see the buttons appear at the bottom of the iPhoto window. If you don’t see all of your choices, click on the arrow (>>) and you will see them.

Using the Calendar Tool (NEW)

iPhoto 5 allows you to quickly display photos from any month, week, or day that you choose. However, you can only use this tool from within the iPhoto Library or an album.

1. Select Library or an album in the Source list.

2. Click the Calendar button (Figure 11).

3. Click the View arrow (A in Figure 12 below) to switch between year- and month-view. (Click the Up or Down arrow at the top of the calendar to scroll to another year or month.)

4. Do one of the following:

   To display photos from a specific month, click a month in year-view.
To display photos from multiple months that are next to each other, click the first month, and then hold down the **Shift** key and select the last month. You can also press the first month and drag to include additional months.

To display photos from multiple months that are not next to each other, select the first month, and then hold down the **Command** key and click additional months.

To display photos from a specific day, double-click its month in year-view, and then click the day.

To display photos from multiple days that are next to each other, double-click their month in year-view, click the first day, and then hold down the **Shift** key and select the last day. You can also press the first day and drag to include additional days.

To display photos from multiple days that are not next to each other, double-click their month in year-view, select the first day, and then hold down the **Command** key and click additional day.

To select a specific week, double-click its month in year-view, and click the dot to the left of the week.

To select the same month, week, or day across multiple years, press the **Option** key while selecting.

5. To display all the photos in your library or album again, click the "x" next to the calendar year (B in Figure 12 above).

---

**Assigning Keywords & Searching Photos**

Another method of organizing photos is to assign keywords to the photos, which are then later searchable. Keywords are also great for setting up criteria for Smart Albums.

The first thing you will need to do is to create your own keywords by editing the keyword list in Preferences. (Note: Editing a keyword in iPhoto Preferences changes that keyword in any photos to which you have assigned it.)

**To add a new keyword to the Keywords list:**

1. Choose iPhoto > Preferences.
2. Click the Keywords button at the top of the window.
3. Click Add.
4. Type your new keyword.

**To rename an existing keyword:** Click the keyword you want to change, click **Rename**, and then type a new name.

**To delete a keyword from the Keywords list:** Click the keyword, and then click **Delete**.

Once you add a keyword to the Keywords list, you will need to assign it to the appropriate photos.

**To assign a keyword to your photo(s):**

1. Select the photo or photos you want to keyword.
2. Choose **Photos > Get Info**.
3. Click the **Keywords** button at the top of the Photo Info window.
4. Select the keyword or keywords you want assigned to the photo. (Note: Selecting the checkmark button adds a checkmark to the lower-right corner of a photo’s thumbnail.)
5. In order to view the keywords assigned to photos, make sure that **Keywords** has a checkmark next to it in the **View** menu.

**To remove a keyword from a photo:** Select the photo, choose **Photos > Get Info**, click the **Keywords** button at the top of the Photo Info window, and deselect the keywords you want removed.

An alternative method to assigning keywords is to use the Keyword pane that is new to iPhoto 5. Click on the **Keyword pane** shown in Figure 13 below and then drag selected photos **over the keyword** you desire to assign them to. You can also remove a keyword by pressing the **Option** key and dragging the photo(s) onto the keyword in the Keywords pane or simply dragging the photos over the **Reset (x)** button in the Keywords pane.

![Figure 13: Keyword Pane in iPhoto 5](image)

Now you will be able to search for any photo by its keyword.

**To find photos that contain a specific keyword:**

1. Select the Library icon or select an album, slideshow, or book that contains the photos you want to search.
2. Click the **Keyword** button (shown above in Figure 13).
3. To display photos that contain a specific keyword, **click** the keyword in the Keywords list. You can select more than one keyword to narrow your search.
4. To hide photos that contain a specific keyword, click the keyword in the Keywords list while pressing the Option key. You can select more than one keyword to narrow your search.

5. To display all photos again after you've finished a search, click the Reset (x) button.

A new feature in iPhoto 5 is the ability to search for any photo by text contained in its film roll, title, comments, keywords, or filename by typing its text in the Search box.

**To search for a photo by its film roll, title, comments, keyword or filename:**

1. Select the Library icon or select an album, slideshow, or book that contains the photos you're looking for.
2. Type text in the search field (shown below in Figure 14).
3. As you type, photos that contain the text you entered will appear in the iPhoto window.
4. To see all photos again, click the Reset button (i.e., the little "x" in the search field box).

![Figure 14: iPhoto 5 Search Box](image)

**Editing Photos with the Enhance Button**

If a photo didn’t turn out like you had hoped, you may use iPhoto’s Enhance button to enrich the color or manipulate the contrast.

1. Click on the photo in your photo album that you wish to enhance and then click the Edit button in the button bar at the bottom of the iPhoto window as shown in Figure 15 below.

![Figure 15: Edit Button](image)

2. In Edit mode, you will see a button labeled Enhance. Click on the Enhance button and watch closely as iPhoto enhances the photo. (Note: Sometimes the change is dramatic and other times it is quite small.)

![Figure 16: Enhance Button](image)

3. To compare with the way the photo looked originally, in this Edit window, hold down the Control key. Toggling back and forth with the Control key will let you compare how the enhance adjustment affected the photo.

4. When you are done with enhancing a photo, click the Done button and iPhoto will save the changes and take you back to the location you were originally at (i.e., Library or photo album) before entering the Edit window. You may also choose to enhance several photos without exiting Edit view by simply selecting a new photo to edit from the photo browser at the top of the iPhoto window and clicking the Enhance button to change the photo. (Note: If you don’t see a row of photos at the top of the window, choose View > Thumbnails.)

5. Note: If you decide you don’t like the enhancements and you just want to return to the original version of your photo, go to the Photo menu and select Revert to Original. The Revert to Original dialog box will appear saying, “All changes will be lost. Are you sure you want to revert to the original version?” If you wish to revert, click on the OK button and you will see your photo again in the original, unenhanced version of the photo.

**Removing “Red Eye” from Photos**

If your photo happens to have the dreaded “red-eye” effect, follow the instructions below to eliminate it:

1. Select the photo with the red-eye problem and click on the Edit button to view it in the Edit window.
2. Zoom in on the area of red eye that you wish to edit by dragging the size control on the Zoom Slider (Figure 17).

![Figure 17: Zoom Slider](image)

3. Click the Red-Eye button to turn on the red-eye tool.
4. You will notice that the cursor has changed into a crosshair. Position the crosshair pointer over the center of one of the subject’s pupils, and then click the mouse button. Repeat this step for the other eye.
5. Click the Red-Eye button again to turn off the red-eye tool.

6. After reducing red-eye, you can press the Control key to compare the edited photo to its previous version.

7. Click the Done button to return to library, album, slideshow, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose View > Thumbnails.)

---

**Retouching a Blemish in a Photo**

The Retouch tool in iPhoto is very handy for removing small facial blemishes or other imperfections in a picture. Warning: The Retouch tool is intended for very small mistakes or errors in a photo. If you use it to work on a large area of a picture, it will end up looking rather blurry and will actually draw too much attention to the blemish. Also, note that retouching a photo changes its appearance in the iPhoto Library and every album where it appears. To edit a photo without changing it, take a duplicate of the photo and use the brush-type strokes.

**Figure 18: Retouch Button**

3. Click on the Retouch button and then begin moving over the blemish on the photo with your mouse that you wish to fix by making “brush-type” strokes.

4. If you wish to zoom in so that you can select the area more easily, simply drag the Zoom slider.

5. Remember, you can always check to see what the original photo looked like by using the Control key to toggle back and forth or you may revert to the original version by using the Photo > Revert to Original command.

6. Click the Done button to return to library, album, slideshow, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose View > Thumbnails.)

---

**Convert Photo to Black & White or Sepia**

Color images can be converted to black & white or sepia. Black and white conversion is especially handy if you cannot print your images with a color printer; simply change them to black & white for the best printing results. Sepia can give your photos that “artistic touch.”

1. Select the photo in your photo album that you wish to convert to black & white or sepia and click on the Edit button.

2. In the Edit window, you will see the B & W and Sepia buttons in the toolbar. Click on the B & W or Sepia button and iPhoto will take a moment to process it and then strip the color. (Note: Once again, you can check to see what the original color photo looked like by using the Control key and toggling back and forth.)

3. To undo this effect, you can simply select Undo... from the Edit menu at the top of the iPhoto screen (Command-Z) or select Photo > Revert to Original.

4. Click the Done button to return to library, album, slideshow, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose View > Thumbnails.)

---

**Cropping an Image in iPhoto 5**

If there is an area of your photo that you wish to eliminate, you may use the Crop tool to remove the area from the picture.

1. Click on the photo in your photo album that you wish to crop and click on the Edit button.

2. In the Edit Window, your cursor will transform into a crosshair. Take the crosshair and drag a square or rectangle over the image to select the area you wish to retain. (Note: Once you release the mouse, if you need to enlarge or decrease the cropping box you created with the crosshair, simply drag from the outer edges.)

3. Click on the Crop button in the toolbar.

4. iPhoto removes the area of the photo that was not included in the crosshair.

5. If you wish to view the original photo, click on the photo and use the Control key to toggle back and forth between the cropped and the uncropped image.

6. Click the Done button to return to library, album, slideshow, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose View > Thumbnails.)
Constraining Proportions When Cropping

Another method you can use when cropping is to constrain the proportions of the area of the photo that you select to crop.

1. Click on the photo in your photo album that you wish to crop and click on the **Edit** button.
2. Down in the Edit toolbar, you will see a pull-down menu with the word “**None**” above the word **Constrain** (Figure 19 below).
3. Select a size from the list (e.g., 4 X 6 Postcard)

![Figure 19: Constrain Pull-Down Menu](image)

4. Now when you go into the picture to select an area to crop with the crosshair, you will have a set size proportion. The cursor will change into a hand. With the hand, move around the proportion window so that it fits the area you want to crop. No matter how large you make the cropping, the ratio of the width and height will stay the same.
5. Click on the **Crop** button and you will see that the cropping is constrained to the 4 X 6 proportion that you chose with the crosshair.
6. Click the **Done** button to return to library, album, slide-show, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose **View > Thumbnails**.)

The Adjust Button in iPhoto 5 (NEW)

With the Adjust button, iPhoto 5 includes new editing options for improving a photo’s exposure, gray balance, sharpness, brightness and contrast, color adjustment, straightening, and saturation in order to assist you in fixing those not-so-perfect shots (none of us have those, right?).

Note: Adjusting a photo with this tool changes its appearance in the iPhoto Library and in every album, slideshow, and book where it appears. To edit a photo without changing it everywhere it appears, make a duplicate (Command-D) before editing.

1. To use the **Adjust** tools, click on the photo in your photo album that you wish to crop and click on the **Edit** button.
2. Click on the **Adjust** button (Figure 20 below).

![Figure 20: Adjust Button](image)

3. Drag the slider controls for **Brightness**, **Contrast**, **Saturation**, **Temperature**, **Tint**, **Sharpness**, **Straighten**, and **Exposure** and adjust to the level you desire (see Figure 21 below).
4. After adjusting the sliders in a photo, you can press the **Control** key to compare the edited photo to its previous version. To reset the photo to its initial settings, click **Reset Sliders**.
5. If you don’t like the changes you’ve made to a photo, you can undo your most recent change by choosing **Edit > Undo**. You can also revert to the photo’s original version by choosing **Photos > Revert to Original**.
6. Click the **Done** button to return to library, album, slide-show, or book view; or select a new photo to edit from the photo browser at the top of the iPhoto window. (If you don’t see a row of photos at the top of the window, choose **View > Thumbnails**.)

![Figure 21: Adjust Dialog Box](image)
Creating a Photo Slideshow in iPhoto 5

You can convert your photo albums into slide shows and include music to play from your iTunes library as well.

1. Select a photo album and choose File > New Slideshow.

2. Drag photos into the order you want in the Photo Browser at the top of the iPhoto viewing area.

3. Note: After you create a slideshow, you can also add photos to it by dragging them directly from another album, a CD or DVD, or from another location on your hard disk. When you add a photo to a slideshow from another location on your hard disk, iPhoto automatically imports it into your photo library.

4. Select the various options for transitions and effects for each photo. To view the transitions/effects on an individual photo, click on the Preview button.

5. If you wish to use the same transition and effects globally for the entire slideshow, click on the Settings button to bring up the Settings dialog box and make your selections (Figure 22).

6. Click on the Music button to bring up the Music dialog box (Figure 23) to select the music from iTunes you wish to use in your slideshow.

7. Click the Play button to view your slide show and hit ESC or press the mouse button to stop the slideshow.

8. Note: After you are finished creating a slideshow, you can access it anytime and play it on your computer screen by simply selecting the slideshow you want to play in the Source list. Press the Space bar to pause and resume playing a slideshow. Use the Up and Down arrow keys to adjust the speed of your slideshow. Use the Right and Left arrow keys to move through a slideshow manually. Press Delete to remove the photo currently being displayed from the slideshow. Press Command-R to rotate the photo currently being displayed. Press 0, 1, 2, 3, 4, or 5 to assign a rating to the photo currently being displayed.

Adding Music to iTunes for Slideshows

You can add any track from a CD into your iTunes Library and then use it in your iPhoto slideshow. To add CD tracks to your iTunes Library, follow the instructions below:

1. Open iTunes and from the File menu, select New Playlist (Command-N).

2. Type a name for the new playlist in the Source area (e.g., Music for iPhoto).
3. For the purpose of this class, click on the new playlist you just created and simply open the Fose iPhoto 5 Class folder and then open the AAC iTunes Music folder within it. Shift-select the three AAC (.m4a) files and drag them into the main iTunes window of the playlist. iTunes will copy the files into the playlist and into the iTunes Library. Now skip to step 11 below.

4. If you aren’t using the Fose iPhoto 5 Class files, follow these instructions to import songs into iTunes from a CD: Insert an audio CD into your Mac. After a moment, the songs on the CD will be listed in the iTunes window.

5. Click to remove the checkmark next to any songs you DON’T want to import into your library.

6. Click the iTunes Import button to add the selected songs to your library.

7. The display area at the top of the iTunes window shows how much time it will take to import each song. To cancel import, click the small X next to the progress bar.

8. By default, iTunes plays songs while they’re being imported. You can click the Pause button to pause playback, or continue to use iTunes for other tasks; the import will continue. You can also stop iTunes from playing songs automatically by deselecting the Play songs while importing checkbox in the Importing pane of iTunes preferences.

9. iTunes has just imported the songs from the CD into the iTunes Library. Click on the iTunes Library in the Source list and drag the songs you desire from the Library into your new playlist. To move multiple songs, click the Command key or the Shift key and click on the songs you desire and then drag them together as a group into your new playlist.

10. To remove a song from a playlist, select it and hit the Delete key. (Note: This does not remove it from the iTunes Library or from the hard disk.)

11. Now, go into iPhoto and select the slideshow that you created and click on the Music button. Select the new playlist you created from the pull-down menu (e.g., Music for iPhoto) and then select the tune you wish to use in your slideshow in the list that appears or use the Search box to search for the tune. Click the OK button to close this dialog box and save your choices.

---

Export a Slideshow as a QuickTime Movie

This is a cool feature of iPhoto. Did you know that you can export your slideshow into a QuickTime movie and play it on any computer that has QuickTime installed (Mac or PC)? To make a QuickTime movie of your photos, follow the steps below:

1. Select the album of photos you want in your movie. Make sure that none of the photos are selected by choosing Edit > Select None; otherwise, you’ll have a movie of only the photos that are selected in the album.

2. Choose Share > Export…

3. When the Export Photos dialog box appears, click on the QuickTime tab (see Figure 25).

4. In the QuickTime pane, change the desired options:

   **Images:** Specify the maximum dimensions of your movie in pixels and set the display duration for each photo.

   **Background:** To add a background color to your movie, click the Color button, then click the color preview box to change the color. To add a background image, click the Image button, then click Set to select an image.

   **Music:** Choose whether to include the same background music selected in the Slideshow Settings window.

5. Click Export.
6. Type a name for your movie and choose where to save it.
7. Click Save.

Export a Slideshow as HTML Web Pages

This is another really cool feature of iPhoto. Did I say that all of the features are cool? You can export your slideshow into HTML so that it is organized on a web page for you with thumbnails that visitors can click on and see a larger version of your prized photos. Here’s how:

1. Make a new folder on your Desktop (Command+Shift+N) and give the folder a title (e.g., iPhoto Web Page)
2. Open iPhoto and select the photo album you wish to make into a web page. Make sure that none of the photos are selected by choosing Edit > Select None; otherwise, you’ll have a movie of only the photos that are selected in the album.
3. Go to Share > Export…
4. When the Export Photos dialog box appears, click on the tab labeled Web Page.

5. In the Web Page pane, change the desired options:
   - **Page**: Type a name for your web page and specify the number of columns and rows per page. To add a background color, click the Color button, then click the color preview box to change the color. To add a background image, click the Image button, then click Set to select an image. To change text color, click the Text Color button.
   - **Thumbnail**: Specify the maximum dimensions in pixels for your photo thumbnails. Click the “Show title” or “Show comment” checkbox if you want your thumbnails to have titles or comments.
   - **Image**: Specify the maximum dimensions in pixels for your photos. Click the “Show title” or “Show comment” checkbox if you want titles or comments to appear on your web page.

6. Click Export.
7. Navigate to the new folder (i.e., iPhoto Web Page) that you created on the Desktop earlier in Step 1 above and click the OK button to save your web page. By doing this, all the content for the web page is placed in one folder for easy upload to a server or to your Site folder in your .Mac account. iPhoto will create a .html file that has the same name as the new folder you previously created on the Desktop and will also generate three folders within your main folder that contain images, pages, and thumbnails.
8. To preview your page before publishing it on a web server, drag the page into your browser (e.g., Safari, Internet Explorer, or Netscape). Notice how the main .html page with thumbnails allows you to double-click on an image and see the larger image. iPhoto has also generated web pages for the larger images, which also allows for navigation to previous or next images.
9. NOTE: Be sure when you upload these files onto a web server that you upload the entire folder containing all the subfolders on the web site.

Exporting Photos for Other Purposes

You may wish to export your photos from an album to send to someone in an email or to import into another application. iPhoto makes this task very simple and allows you to configure the exact size of the exported photos.

1. Create a new folder on your Desktop (Command+Shift+N) and give it a name (e.g., Photos Export)
2. Select the photo(s) or a photo album you want to export.
3. Choose Share > Export…
4. When the dialog box appears, click the File Export tab (Figure 27).
5. In the File Export pane, change the desired options:

   **Format:** Choose a file format for your exported images from the pull-down menu (e.g., Original, JPG, TIFF, or PNG)

   **Size:** If necessary, scale the images to a specific size by specifying a maximum width and height.

   **Name:** Choose whether to export photos with their filenames, iPhoto titles, or album name.

   **Extension:** Choose whether to add the file format extensions (such as .jpg or .tiff) to the end of the photos' filenames, titles, or album names.

6. Click the Export button.

7. Navigate to the new folder you created previously on your Desktop (i.e., Photos Export) and then click the OK button to save the files in their new format to the folder.

---

**Creating a Photo Book**

You can choose from a variety of book sizes and designs to create photo albums for any occasion.

1. Select an album or group of photos you want in your book.

2. Choose **File > New Book**.

3. Choose a hardcover or softcover book size from the **Book Type** pop-up menu. (Note: Softcover books are a new feature in iPhoto 5.)

4. Select a design for your book from the scrolling themes list.

5. When you select a book theme, you can see an example of it in the window to the right of the themes list. If you want to go to the iPhoto website to see detailed book descriptions and pricing, click the **Options + Prices** button.

6. If you chose a hardcover book and want photos to be printed on only one side of your book pages, deselect the “**Double-sided pages**” checkbox.

7. Click **Choose Theme**.

8. Do one of the following:

   - If you want iPhoto to automatically design your book by arranging the selected photos on each page for you, click **Automatically**.
   - If you want to drag the selected photos into the book yourself, click **Manually**.

iPhoto switches to book view, and your new book appears in the **Source** list.

9. Once you create a book, you can change the order of pages or photos, add and change the appearance of text, and even customize the design of individual pages.

10. For more information on specific settings and features of creating a photo book, please refer to the **Help** menu in iPhoto and type in the search word “book”.

---

**Sending a Photo Through Email**

You can also send photos from your iPhoto Library or from photo albums directly from iPhoto with the help of your email program.

1. Select the photo or photos you want to mail. (Note: You can’t email photos from a slideshow or book.)

2. Choose **Share > Email** or click on the **Email** icon at the bottom of the iPhoto window.

---

**Figure 27: Export Photos - File Export**

**Figure 28: Mail Photo Dialog Box**
3. Choose a size in pixels for your emailed photos from the Size pop-up menu.
4. Choose whether to include titles and comments.
5. Click Compose.
6. iPhoto opens a New Message window in Mac OS X Mail with the photo or photos attached. (Note: If you want to mail photos using Entourage, Eudora, or AOL, install the application on your computer, choose iPhoto > Preferences, click General at the top of the Preferences window, and then choose the application from the "Mail using" pop-up menu.)
7. Enter an address, a subject line, and the text of the message, then click Send.

**IMPORTANT:** If you send many large photos in a message, it will take longer for people to download them. It’s a good idea to limit the size and number of photos you send in an email.

---

**Print a Photo as a Greeting Card**

You can print out your photos in a number of different ways:

1. Go to File > Print...

   ![Figure 29: Print Dialog Box](image)

   2. You will see from the **Style**: pop-up menu that there are quite a few different choices: Contact Sheet, Full Page, Greeting Card, N-Up, Sampler, and Standard Prints.

   3. To create a greeting card, select Greeting Card from the **Style**: pop-up menu and then choose the **Style**: radio button you desire next to Single-fold or Double-fold.

   4. Select the number of copies you wish to have printed and click on the **Print** button.

---

**Export a Photo in PDF Format**

You can save a photo or an photo album as a PDF file.

1. Click on a photo album and click on an individual photo.

2. Go to File > Print... and select the **Style** you desire. However, instead of selecting the **Print** button, click on the **Save as PDF...** button.

3. When the **Save to File** dialog box appears, navigate to where you wish to save it and in the **Save As...** textbox, type the name of the file and add the .pdf extension.

4. Click on the **Save** button and iPhoto will save the photo as a PDF and place it in the location where you told it to save the file.

---

**Burn a Photo Album to a CD or DVD**

iPhoto has a built-in feature that allows you to put your iPhoto Library or a specific photo album or even specific individual pictures on a CD or DVD and burn them.

1. Click on a photo album or your entire iPhoto Library (this is great for backups).

2. Select Share > Burn Disk... or click on the **Burn** icon at the bottom of the iPhoto window.

   ![Figure 30: Burn Button](image)

3. iPhoto will open your CD tray and then prompt you to insert a blank disk. Insert a blank CD-R, CD-RW, DVD-R or DVD-RW disk into the drive and click **OK**.

4. Disc information appears at the bottom of the iPhoto viewing area. The green area on the disc icon represents the amount of disc space your photos require.

5. If necessary, type a new name for the disc in the **Name** field and then click the **Burn** button.

6. Click the **Burn** button in the **Burn Disc** dialog.

7. It may take several minutes to write the disc. You can cancel the burn by clicking the **Stop** button next to the progress bar, but if you’re using a CD-R disc, you might not be able to use the CD after canceling.

---

**Set a Photo to Your Desktop Background**

You probably already know that you can easily set a photo or image to be the background Desktop image for your computer by going into your System Preferences and making the appropriate changes in the Desktop & Screensaver area, but iPhoto will allow you to do this right within iPhoto.
NOTE: DO NOT DO THESE NEXT STEPS IF YOU ARE IN A LAB!

iPhoto makes it easy for you to assign any picture in the iPhoto Library as your Desktop image.

1. Select the photo in the photo library or an album.
2. Choose Share > Desktop or click on the Desktop icon at the bottom of the iPhoto window.
3. The Desktop will change displaying the photo that you selected as the background image.
4. You can also have your desktop image cycle through a series of photos. Select an album and make sure that none of the photos in the album are selected by choosing Edit > Select None. Choose Share > Desktop and when the Desktop & Screen Saver dialog box appears, click on the Desktop tab. Select how often you want the picture to change (e.g., Every 30 minutes, every hour, every day, etc.) from the “Change picture” pop-up menu at the bottom of this dialog box and make sure the checkmark is selected next to it. Close out this dialog box to save your changes.

![Figure 31: Desktop Dialog Box](image)

To protect your display, you can set a screen saver to appear automatically if your computer hasn’t been used for several minutes. If you want, you can use an album from your iPhoto Library as your screen saver. The photos appear one after the other, like a slideshow.

1. Select an album and choose Edit > Select None.

2. Choose Share > Desktop and when the Desktop & Screen Saver dialog box appears, click the Screen Saver tab. “Start screen saver” control.

![Figure 32: Screen Saver Dialog Box](image)

3. To choose when the screen saver starts, drag the “Start screen saver” control.
4. If you want to set a different album as the Screen Saver instead, select it from the Screen Savers list on the left of this dialog box.

iPhoto 5 Keyboard Shortcuts

You can use your keyboard to quickly accomplish many tasks in iPhoto. To find the shortcuts for common commands, look in the menus (or see the menu shortcuts below). To do an action, press the keys indicated below.

![Figure 31: Desktop Dialog Box](image)
<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Photos</td>
<td>Shift-Command-I</td>
</tr>
<tr>
<td>Move to the top of the photo library</td>
<td>Home</td>
</tr>
<tr>
<td>Move to the bottom of the photo library</td>
<td>End</td>
</tr>
<tr>
<td>Create new album</td>
<td>Command-N</td>
</tr>
<tr>
<td>Create new album from selection</td>
<td>Shift-Command-N</td>
</tr>
<tr>
<td>Create new Smart Album</td>
<td>Option-Command-N</td>
</tr>
<tr>
<td>Show or hide titles</td>
<td>Shift-Command-T</td>
</tr>
<tr>
<td>Show or hide keywords</td>
<td>Shift-Command-K</td>
</tr>
<tr>
<td>Show or hide film rolls photos</td>
<td>Shift-Command-F</td>
</tr>
<tr>
<td>Show or hide all film rolls photos</td>
<td>Hold down the Option key and click the triangle next to any film roll</td>
</tr>
<tr>
<td>Show or hide ratings</td>
<td>Shift-Command-R</td>
</tr>
<tr>
<td>Set the title, date, or comments of multiple photos</td>
<td>Shift-Command-B</td>
</tr>
<tr>
<td>Assign, edit, or search by keywords</td>
<td>Command-K</td>
</tr>
<tr>
<td>Show a photo’s image and camera information</td>
<td>Command-I</td>
</tr>
<tr>
<td>Duplicate a photo</td>
<td>Command-D</td>
</tr>
<tr>
<td>Cut photo</td>
<td>Command-X</td>
</tr>
<tr>
<td>Copy photo</td>
<td>Command-C</td>
</tr>
<tr>
<td>Paste photo</td>
<td>Command-V</td>
</tr>
<tr>
<td>Move photo to Trash from the library or remove photo from album</td>
<td>Delete</td>
</tr>
<tr>
<td>Move photo to Trash from album</td>
<td>Command-Option-Delete</td>
</tr>
<tr>
<td>Open photo in its own window or in edit view (depends on the double-click preference you set)</td>
<td>Double-click the photo</td>
</tr>
<tr>
<td>Select a single photo</td>
<td>Click the photo</td>
</tr>
<tr>
<td>Select all photos</td>
<td>Command-A</td>
</tr>
<tr>
<td>Select all photos between the current selection and a non-adjacent photo</td>
<td>Hold down the Shift key and click the non-adjacent photo</td>
</tr>
<tr>
<td>Select photos that are non-adjacent to each other</td>
<td>Select the first photo, then hold down the Command key and click additional photos</td>
</tr>
<tr>
<td>Select several photos located together</td>
<td>Click outside the photos and drag to enclose them within the selection rectangle</td>
</tr>
<tr>
<td>Select all photos in a film roll</td>
<td>Click the film roll icon</td>
</tr>
<tr>
<td>Deselect specific photos in a group of selected photos</td>
<td>Hold down the Command key and click the photos you want to deselect</td>
</tr>
<tr>
<td>Deselect all photos</td>
<td>Shift-Command-A or click outside a photo</td>
</tr>
<tr>
<td>Assign zero stars to a photo</td>
<td>Command-0</td>
</tr>
<tr>
<td>Assign one star to a photo</td>
<td>Command-1</td>
</tr>
<tr>
<td>Assign two stars to a photo</td>
<td>Command-2</td>
</tr>
<tr>
<td>Assign three stars to a photo</td>
<td>Command-3</td>
</tr>
<tr>
<td>Assign four stars to a photo</td>
<td>Command-4</td>
</tr>
<tr>
<td>Assign five stars to a photo</td>
<td>Command-5</td>
</tr>
<tr>
<td>Stop a slideshow</td>
<td>Press the mouse button</td>
</tr>
<tr>
<td>Pause and resume playing a slideshow</td>
<td>Press the Space bar</td>
</tr>
<tr>
<td>Adjust the speed of a slideshow</td>
<td>Use the Up and Down Arrow keys</td>
</tr>
<tr>
<td>Move through a slideshow manually</td>
<td>Use the Right and Left Arrow keys</td>
</tr>
<tr>
<td>Rate photos in a slideshow</td>
<td>Press 0, 1, 2, 3, 4, or 5</td>
</tr>
<tr>
<td>Rotate photo clockwise</td>
<td>Command-R</td>
</tr>
<tr>
<td>Rotate photo counter clockwise</td>
<td>Option-Command-R or press the Option key while clicking the Rotate button</td>
</tr>
</tbody>
</table>
Tips on Purchasing a Digital Camera

In order to make the best choice when buying a digital camera, you need to think about how you will be using it. Will you be printing pictures or emailing pictures or publishing them on the web? Will you be taking most of your pictures indoors or outdoors? Will you be taking pictures mostly in the day-time or at nighttime? Will you be taking portrait or landscape shots? Will your subjects be in action shots or mostly stills?

Here are some issues you should consider when purchasing a digital camera:

1. **Resolution**: This refers to the number of dots or pixels per image. Resolution directly impacts the size of a picture you can print. Put simply, more pixels translates into a larger picture that still looks good. With a higher resolution, the camera has captured more detail and doesn’t have to "guess" or interpolate at the missing dots or expand the existing ones which often results in a blotchy-looking print. Thus, the more pixels there are the better the resolution and the quality of the printed image. In the past, older cameras offered 1- to 2-megapixels; however, newer cameras are now offering up to 8-megapixels. As a rule of thumb, a 2-megapixel camera can produce a good 5 X 7 print; a 3-megapixel camera produces an excellent 8 X 10; and a 4-megapixel camera or above, will result in a good 11 X 17 print. Obviously, the manner in which you plan to use the camera will help you to determine the amount of resolution you need.

2. **Size, Weight and Design**: Cameras range in size from 6.8 ounces to 2.6 pounds. If portability is important, consider the size and weight of the camera. Smaller cameras are convenient, but also have smaller dials and buttons that could make using them more difficult.

3. **Zoom Lens**: Some cameras offer optical zoom, while others have digital zoom. Optical zoom moves the lens to magnify the subject, while digital zoom only captures fewer pixels and magnifies them. This clearly jeopardizes the quality of the image. It is recommended that for best results, go with at least a 2X optical zoom.

4. **Focus**: Digital cameras usually offer automatic focus, which for most of us is sufficient. For the few cases where the camera cannot get a focus lock in a close-up shot, a manual focus can be helpful.

5. **Storage**: Storage refers to the medium where pictures are stored once taken. In a conventional camera, that would be the film; however, in digital cameras, storage ranges from floppy disks to compact disks to memory cards. Floppy disks are the least expensive storage medium but storage on them is slow and the disks can only hold one or two high-resolution images. Compact disks store more images, but the cameras that use them are big and bulky. Memory cards are the most expensive, but this storage medium allows for the most flexibility in camera size as well as storage capacity. While most cameras have onboard storage, investing in additional removable storage allows for expansion of storage capacity.

6. **Movies and Sound**: Some cameras offer the option of video capture. This is handy if you do not have a video camera, but since video takes up more storage space than images, the video clip on a still camera can usually not be longer than 30 seconds.

7. **LCD Screen**: Probably one of the most compelling reasons to purchase a digital camera is that you can see the image right away and decide whether or not you like it and want to keep it. To do so, however, you need an LCD screen on the camera. Low-end models often omit this option, thus taking away one of the best features of digital cameras. This is one feature you should NOT go without! Be sure to try the camera before you buy it. However, since some screens wash out in the sunlight, making it difficult to see when taking pictures outdoors.

8. **External Memory Card Readers**: These are similar to external hard drives that you may attach to a computer. Memory card readers allow you to download pictures directly from the storage medium, which will save you time as well as battery life.

Using iPhoto in the Classroom

Digital cameras offer teachers unlimited opportunities to engage students and to incorporate technology into their curriculum. At Cal Poly students, faculty, and staff can check out digital still cameras from Media Distribution Services (http://mds.calpoly.edu) in Building 2 on the first floor. Check out a camera and experiment with some student projects.

Here are some examples of projects you can assign:

1. Assign pairs of students to take pictures on a topic related to class and compose their own iPhoto slideshow; then have them describe the slideshow to the class in a class presentation as it plays on a data projector or post it into Blackboard.

2. Have foreign language students take pictures of everyday things and put into an iPhoto slideshow or web page with a title and comments in Spanish/French/Italian vocabulary. Or if you prefer, keep the pictures in an iPhoto album arrangement and have them printed out for a classroom “Pictionary” so your students can quiz each other on foreign language vocabulary in class.

3. Take photos of your students the first day of class with your digital camera and create a directory that you can post in Blackboard to acquaint the students with one another.

4. Take photos of your students the first day of class and export the pictures into small images that you can import into a Word document. Add names and useful information about the students to help you remember them. This is a great way to help you learn students’ names more quickly, especially in a large lecture hall.

5. Take a picture of each student in your class and send the file with the iPhoto email tool for the student to post in Blackboard with their own personal Blackboard home page. On their home page, students can share information about themselves with their classmates, express career interests or favorite links.

6. Take a digital camera on a class field trip. When you return to the classroom, have each student select a picture to label with a short description of what was happening or why this was important; then print a copy for everyone so they can remember what they learned on the trip.

7. Document the growth of a school project: (e.g., a school construction project; planting and growing of a class garden; changes in animals in a laboratory, etc.) Assign a new “class photographer” every week and have them document moments that demonstrate “learning in action” with a short description of what was happening and post the photos and descriptions in Blackboard.

8. Take photos of student final projects in 3-D form and post them in Blackboard.

Obviously, this is just a short list of the many ways a digital camera can enhance instruction in the classroom. Enjoy yourself! Be creative! Think up some projects that will work for your discipline and get out there and start snapping photos!