
SITE MANAGEMENT 
 
INTRODUCTION 
 
Those of you who have already built Web pages will likely agree that file management is one of 
the biggest challenges of this medium. By file management, I mean the organization, folder 
structure, and naming conventions of all the pages and graphics in your web site. Few other 
disciplines require the creation of so many documents at once, because web pages are usually 
comprised of numerous text and image files. 
 
To compound the difficulty of managing lots of files, most people build web sites from their hard 
drive, and when they finish, they upload these files to a Web server so that the files can be 
viewed from the Web. Let's say that you created a folder on your hard drive and called it 'HTML' 
and created another folder called 'graphics.' If you put your HTML and graphics files inside those 
two folders, you would have to replicate this EXACT folder structure when you upload those files 
to your Web server, or your links to those files would break. 
 
Dreamweaver has a sit-management scheme that requires that you keep all of your files within 
one main root folder, so you can easily duplicate the folder structure that's on your hard drive 
when you upoload to a Web server. A root folder is no different than any other kind of folder 
on your hard drive, except that you have specified to Dreamweaver that all your web 
development will take place here. 
 
Taking it one step further, let's say that you decided midstream to change the folder hierarchy of 
your site by adding a folder or changing a folder name. If you were hand-coding the pages, it 
would be a real pain to make these changes. Dreamweaver makes this process painless, as long 
as you work within its site-management structure. 
 
 
DEFINING A SITE 
 
You will be working with a folder of HTML and image files that are already in your lib302 folder 
inside the folder named after your computer. The folder is named chap_03. It is best to just leave 
it named that. 
 
1. Open Dreamweaver and press F5 to bring up the Site window. (Or press the Site button on 

the Launcher.  
2. On the pop-up menu select Define Sites. (Note: If you have worked in Dreamweaver before, 

and have already defined other sites, you would click New.) This will open the Site Definition 
window as shown on the next page. 

 

C:\Documents and Settings\default\Desktop\judy\DWSiteMgmt.doc 1 12/11/02 



3. Type Site Management for the Site Name. (This is an internal naming convention so you 
can use any kind of name you want without worrying about spaces or capitalization. Think of 
it as your own pet name for your project). 

4. Click on the small yellow folder icon to the right of the Local Root Folder text box. Browse to 
the siteManagement folder that is in the my documents folder.  

5. Click OK. 
6. Pub a check in the Use Cache to Speed Link Updates. This will increase the speed with 

which Dreamweaver performs its link-management features. 
7. Click OK. Another dialog box will appear indicating that the initial site cache needs to be 

created. You can choose not to have this message displayed in the future by clicking on the 
check box (highly recommended). 

8. Click OK. After the site cache has been created, you will be brought back to the Define Sites 
window. 

9. Click Done. 
 

 

The Site Window is 
now defined as Site 
Management. The 
list represents all the 
files inside the
documents folder.  

 my 

 
ORGANIZING A LOCAL SITE 
 
When creating a site, start by setting up the basic structure of the site on your local disk. (If you 
already have a local site on your computer, a site that you created outside of Dreamweaver, see 
the Editing an existing local site article.) If you already have a remote site on a Web server and 
you want to use Dreamweaver to edit that site, see the Editing an existing remote site article.) 
 
Organizing your site carefully from the start can save you time and prevent frustration later on. To 
set up a site, create a folder on your local disk to hold all the files and subfolders for your site 
(including HTML files, image files, Cascading Style Sheets, and so on), then create and edit 
documents within that main folder. The folder that contains everything in your local site is called 
the local root folder. 
 
Here are some suggestions for creating an organized site: 
 

• Put all your sites in one place. Create a folder named Sites, and then create local root 
folders inside that folder. Use a separate local root folder for each site you're working on. 

• Break down your site into categories. Put related pages in the same folder. For example, 
your company press releases, contact information, and job postings might all go in one 
folder, and your online catalog pages in another folder. Use subfolders where necessary. 
This type of organization will make your site easier to maintain and navigate. 
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• Decide where to put dependent files such as images and sound files. It's convenient to 
place all your images, for example, in one location, so that when you want to insert an 
image into a page you know where to find it. Designers sometimes place all of the non-
HTML items to be used on a site in a folder called assets; you can create subfolders of 
the assets folder for images, sounds, and so on. 

• Use the same folder structure for local and remote sites. Your local site and your remote 
Web site should have exactly the same folder structure. If you create a local site using 
Dreamweaver and then copy, or upload, everything to the remote site, Dreamweaver 
ensures that the remote site's structure is a precise duplicate of the local site. 

 
GETTING YOUR PAGES ONLINE 
 
In order for your site to be seen on the World Wide Web, your files need to be uploaded to a live 
Web server. In Dreamweaver, the files on your hard drive are referred to as local files and the 
files on a live web server are referred to as remote files. 
To access the FTP component of Dreamweaver 
 
1. press F5, and select Define Sites. 
2. Choose Chapter 3 and click Edit 
3. Click on the Web Server Info, and Choose FTP from the pull-down menu. 
4. Fill in the boxes as they are in the image below, except put in your login and password. 
5. Click OK.\ 
6. You should see the inside of your public_html folder from your polylog account appear on the 

left window of Dreamweaver's Site Window. 
 

 
 
It is important to note that you do not have to use Dreamweaver to exchange files with a remote 

server. You can use other FTP applications as well, such as Fetch (Mac) and WS_FTP 
(Windows), 
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RELATIVE AND ABSOLUTE LINKS 
 
This exercise will help you understand two different types of links - those that are relative and 
those that are absolute. Relative links reference files that are part of your site. If you want to link 
to an external file, such as someone else's site, you have to use an absolute link. 
 
1. Press F5 to make sure that the Site window is open. Look into the right side of the Site 

Window to the Local Folder and double-click on index.html to open it. 
2. You will see the following page: 

 
 
3. Single-Click on the "about the inn" (about.gif) image at the bottom of the screen to select it. 
4. Once the image is selected, the Properties Inspector Window changes to show you the 

properties of that particular image. 
 

 
 
5. Notice that this image links to about.html. The link about.html is a relative link. It does not 

have additional information in front of it such as: http://www.whatever.com/about.html. The 
file does not need that information because the file name is relative to other internal links in 
the site. 

6. Highlight the word Ojai at the bottom of the Document window. (TIP: you can double-click on 
text to select it).  

7. In the Properties Inspector, notice that this image links to http://www.ojai.org This is an 
external link to another site on the Internet. This type of link is referred to as an absolute link. 
It needs that additional information to specify its location on the web. It is not relative to your 
web site, and it exists on server other than yours.  

8. Save and Close the file. 
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FILE AND FOLDER MANAGEMENT 
 
From within Dreamweaver's site window, you can create new folders and files, as well as move 
them around.  This is another reason why you should always work in Dreamweaver for creating 
web sites. It will keep track of where the files have been moved or added.  
 
1. Make sure the Site window is open 
2. Click on the Site Files button in the upper left corner. 
3. Click on the folder at the top of the Local Folder view 
 

 

Site Files 
Button 

 
4. Select Site>Site Files View>New Folder. This will add a new folder to the local folder.  
5. Type html for the folder name and press Return. 
6. Now you will need to select the files to be moved into the folder you just created. Select 

discontinuous files (files that are not adjacent to one another) by; 
• Clicking on the about.html file 
• Then hold press the CMD key+Click on reserve.html, rooms.html, and 

services.html.  
7. Once the four files are selected, drag them to the html folder that you just created. This will 

move all four files into this new location. 
8. When you move the files, Dreamweaver prompts you to update the links. Click the Update 

Button.  Dreamweaver will list all the different files that were affected by the files you just 
moved. Once you click Update, these files will be rewritten automatically to reflect the 
change in the structure. Isn't life grand? 
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UNDERSTANDING THE PATH STRUCTURE 
 
This next exercise builds on Dreamweaver's Site window features, and shows how path 
structures are altered if you move files around. A path structure is simply the route through a 
file system to a particular file.  Both relative and absolute URLs can be configured in a variety 
of different path structures. In this exercise, you will reference files in three distinct ways, each 
demonstrating the different type of file structures you might encounter. 
 
Inserting a file that is within the same folder 
 
1. Make sure the Site window is open. (F5) 
2. Under the Local Folder column, double-click on the paths folder. 
3. Open path1.html. 
4. Choose Insert>Image. Select moontile.gif. 
5. Once you have inserted the picture, look at the Properties Inspector.  
 

 
 
6. Notice that the Src is set to moontile.gif. As you become more experienced with building 

web pages, you will begin to notice that a file name with no slash in it means that the file was 
in the same folder as the HTML that referenced it. 

 
Inserting a file that is inside another folder 
 
1. Delete the image you just inserted by selecting it (clicking on it once) and pressing the Delete 

key. 
2. Choose Insert>Image and open the images folder nested inside the paths folder to select 

moontile2.gif. 
3. Once you have inserted the image, look at the Properties Inspector again. 
 
 

 
 
4. Notice that the Src is now set to images/moontile2.gif. The slash means that the file is 

nested inside another folder.  
5. Save and close path1.html. 
 
 
Opening an html file that is inside a folder, and inserting an image that is outside a folder 
 
1. From the Site Window open path2.html from the html folder nested within the paths 

folder. 
2. Choose Insert>Image and navigate outside the html folder into the images folder to find 

moontile.gif. 
3. Once you have inserted the image, look at the Properties Inspector again.  

C:\Documents and Settings\default\Desktop\judy\DWSiteMgmt.doc 6 12/11/02 



 

 
 
4. Notice that the Src is now set to ../moontile.gif. The two dots before the slash indicate that 

the image was one folder up from the HTML Document that referenced it. 
 

Path Notations in Dreamweaver 
Path Notation Description 

document.gif No slash (/) or dots(..) indicates that the file is inside the same folder as 
the HTML file. 

images/document.gif The forward slash (/) indicates that the file is inside the images folder, or 
the file is located one level down from the HTML file. 

../images/document.gif The two dots (..) indicate that the folder is one level up from the HTML 
file. 

 
 
CREATING A SITE MAP 

The Site Map is a great w  examine the structure of your Web site. It lets you see the different 
levels and what is contain ithin those levels. If you change the structure of the site, the site 
map will change as well. T

1. Press F5 to open the 
2. Click on the Site Map

lets you choose betwe
 

 
3. The Site Map view, s
4. Click on the Site Map

absolute links display
to their right. The rela

C:\Documents and Settings\
ay to
ed w

his exercise will show you how to make a site map. 

Site window. 
 button in the upper-left corner of the Site window. A pull down menu 
en two options, Map Only or Map and Files. 

 

Site 
Map 
Button 

et to Maps and Files, will open in the left side of the window. 
 button, and Choose Map Only. Here you will see the relative and 
ed side by side. The absolute links are in blue and have a small globe 
tive links have an arrow on their left.  
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EDITING AN EXISTING REMOTE SITE 
 
You can use Dreamweaver to copy an existing remote site (or any subfolder of a remote site) to 
your local disk and edit it there, even if you didn't use Dreamweaver to create the original site. 
 
Note that even if you intend to edit only part of the remote site, you must locally duplicate the 
entire structure of the relevant branch of the remote site; from the remote site's root folder down 
to the files you want to edit. For example, if your remote site's root folder, named public_html, 
contains two folders, Project1 and Project2, but you want to work only on the HTML files in 
Project1, you don't need to download the files in Project2. However, you must map your local root 
folder to public_html, not to Project1. 
 

 
 
To edit an existing remote site 
 

1. Create a local folder to contain the existing site, then set it up as the local root folder for 
the site.  

2. Set up a remote site, using information about your existing site. Be sure to choose the 
correct root folder for the remote site. 

3. Connect to the remote site using the Connect button in the Site window. 
4. Depending on how much of the remote site you want to edit, do one of the following: 

a. If you want to work with the entire site, select the root folder of the remote site, 
and click Get to download the entire site to your local disk. 

b. If you want to work with just one of the files or folders of the site, locate the file or 
folder in the Remote pane of the Site window, and click the Get File(s) button to 
download that file to your local disk. (If you've set up the local site correctly, 
Dreamweaver automatically duplicates as much of the remote site's structure as 
is necessary to place the downloaded file in the correct part of the local site 
hierarchy.) When downloading only one part of a site to edit it, you should 
generally choose to include dependent files.  

5. Proceed as if creating a site from scratch: edit documents, preview and test them, and 
upload them again to the remote site. 
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CREATING REPORTS 
 
You can run various types of reports on documents, folders, and sites, sort the results, and get 
additional details about selected results. 
 
To create a report: 
 

1. Choose Site>Reports. The Dialog Box appears. 

 
 

2. Choose a Report category from the Report On pop-up menu. The Report options are 
Current Document, Entire Local Site, Selected Files in Site, or Folder. (You cannot run a 
Selected Files in Site report unless you have already selected files in the Site Window). 

3. Select a report type by clicking the appropriate box. You can select one report, or select 
several to run them simultaneously. 

4. Click Run to create the report. Depending on what you chose to report on, you may be 
prompted to save your file, define your site, or select a folder. 

5. A list of results is displayed in the Results window. 
6. Click Open File to go to the selected item in the Document window. (or double-click on 

the file). 
 
CHECKING LINKS IN A PAGE OR A SITE 
 
Fixing broken links (links that no longer follow a valid path or point to a nonexistent file) on a large 
site can be a tedious and time-consuming problem. This is because a large site can contain 
hundereds of links to internal and external documents, and the links may change over time. 
Orphaned files (files that still exist in the site but are no longer linked to any file in the site can be 
a problem too, because they may take up disk space and confuse others working on the site.  
 
Use the Check Links feature to search for broken links and unreferenced files in an open file, a 
portion of a local site, or an entire local site. The only links that Dreamweaver verifies are links to 
documents within the site; Dreamweaver compiles a list of external links that appear in the select 
document, but it does not verify them. 
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When Dreamweaver has finished checking the links in the specified files, it opens the Link 
Checker Dialog box. This dialog box displays a list of broken links, external links, and orphaned 
files. 
 
To check links in the entire site: 
 

1. Choose Site>Check Links Sitewide. The link checker dialog box appears. 
 

 
 

2. A list of files that fix the report you selected appears in the Link Checker Dialog box. 
3. You can fix broken links and images references directly in the Link Checker dialog box, or 

you can open files from the list and fix links in the Property Inspector. 
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