
Creating Rollovers 
 DREAMWEAVER MX  

Objectives 
In this section you will learn to: 

• Create a Simple Rollovers 
• Create an Animated Rollover 
• Create Pointer Rollovers 
• Create Multiple-Event Rollovers 
• Create an off/on button in Photoshop 

Introduction 
One of the key challenges in Web development is to invent artwork that clearly communicates 
how to navigate through your site. Rollover graphics, which change when your user puts his or 
her mouse over them, are great for adding visual cues that ensure that your audience knows that 
an image has special meaning, for example, that it is a link. Rollovers are also great if you have 
limited space because you can put extra information within the changing graphic. 

Rollovers have been used for years in multimedia presentations as an effective device to indicate 
that an image is a button or is linked to other documents. Rollovers are a relatively new addition 
to the Web, because standard HTML doesn’t offer this feature. Instead, rollovers are written in a 
widely used scripting language invented by Netscape, called JavaScript. 

Dreamweaver automatically writes JavaScript rollovers for you without you ever having to write 
the scripts or even understand how they are constructed. 

The Rollover Rules 
Rollovers require a minimum of two graphics – an “off” state and an “on’ state.  When you make 
you own rollover graphics, your rollover images MUST BE THE SAME SIZE IN DIMENSIONS, 
OR YOU RISK THAT THEY WILL LOOK DISTORTED. JavaScript requires WIDTH and HEIGHT 
information which Dreamweaver will add for you automatically. If you have two different-sized 
pieces of artwork, the JavaScript will scale both to the same width and height, causing distortion.  

Creating a Simple Rollover 
This type of rollover involves two pieces of artwork. The first graphic appears on the screen 
initially and the second appears when the mouse “rolls over” it. In JavaScript terminology, this is 
called a “swap” image.  
1. Launch Dreamweaver MX. You will have the opportunity to choose which site look you want 

to work with. Choose the one on the left. Define your site as Rollovers.  
2. Open star_final.html in the html folder. When you move your mouse over the star, nothing 

happens, right? Press F12 to preview the page. When you move your mouse over it in your 
Web browser, it changes to a yellow star. You can only view a rollover inside a browser 
because Dreamweaver cannot preview this effect.
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3. Return to Dreamweaver and close the file.  
4. Choose File>New to create a new Untitled Document. It is always a good practice to save a 

file before you begin working with it, because Dreamweaver will give you error messages if 
you don’t. Choose File>Save As and name this file simpleroll.html in the html folder. 

5. Choose Insert>Interactive Images > Rollover Image, or click on the Insert Rollover button 
on the Insert Palette.  

6. The Insert Rollover Image dialog box will appear. Use the Browse button to locate the file 
smstar_off.gif inside the images folder. Choose it for the original image. 

7. Choose ssmstar_on.gif for the rollover image. 

 
8. To make pages ADA compliant, you must include Alternate Text to all graphics. Here we 

will add the word star to the Alternate Text field. 
9. Once your dialog box looks like this one, click OK. 
10. To ensure that graphics always contain Alternate Text or an ALT tag, turn on the 

Accessibility reminder. 
11. From the Edit menu, select Preferences. 
12. Select the Accessibility Category and click in the box next to Images. 
13. Click the OK button. 
14. Click on the star once. Notice the hash mark (#) inside the Link area of the Properties 

Inspector?  
Dreamweaver inserted this symbol in order to create a link even though you didn’t specify 
one. Why? Because a link is necessary for the JavaScript rollover to work. Putting a hash 
mark in the Link area inserts a stand-in link that doesn’t link to anything. It simply acts as a 
placeholder so that you can still click on it and see the rollover.  

 
15. In the Link field in the Properties Inspector, click on the yellow folder icon and browse to 

the html folder and select the rooms.html file. Click the OK button. 
16. Press F12 to preview the rollover.  
17. Click on the link to make sure it works. 
18. Return to Dreamweaver, and save and close the document. 
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Animated Rollovers 
This next exercise uses the same technique as Exercise 1, only instead of two static images, the 
Rollover image is an animated GIF. You’ll be putting the rollover graphics inside a table to 
ensure that they don’t move around once they’re in place. 

1. Open index.html located in the html folder. Notice the empty Table where the navigation 
elements belong? This is where you’re going to insert Rollovers for each button. Click inside 
Cell A (row 1, column 1) and from the Insert menu select Interactive Images>Rollover 
Image (you can also go to the Insert Palette and click on the Insert Rollover object). 

2. You will get the following dialog box. For the Original Image, click the Browse...button to 
select about.gif located in the images folder. For the Rollover Image, click the Browse 
button to select about_anim.gif located in the same folder.  

 
3. Click OK. Notice that the table got all smooshed up after you inserted the image? We will fix 

it in a minute. 

4. Press F12 to view the results. When you move your mouse over the about the inn image, 
notice that the Rollover state is an animated GIF? Dreamweaver treats the animated GIF as it 
would any other GIF. 

5. Return to Dreamweaver and click to the right of the about the inn (about.gif) graphic to 
make sure it is deselected. Press the Tab key to move the cursor to the next cell which is now 
scrunched up with the other cells on the right side of the table. 

6. Once your cursor is in Cell B (row 1, column 2) choose Insert> Interactive Images > 
Rollover Image again (or go to the Insert Palette and click on the Insert Rollover object in 
the images folder. For the rollover image, click the Browse...button to select 
rooms_anim.gif located in the same folder. Click OK, 

7. Follow these steps for cell 3 and put services.gif for the Original image and 
services_anim.gif for the rollover image. 

8. Use the same steps for cell 4. Put reservations.gif for the Original image and 
reservations_anim.gif for the rollover image. 

9. Press F12 to view the results in a browser. 
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Animated Gif Rollovers and Preload 
The previous exercise used animated GIF files for one of the rollover states. Dreamweaver 
regards these files no differently than static GIFs. If you make your own animated GIF files in an 
image editor and use them in Dreamweaver as rollover states, there are a couple of GOTCHAS 
you should know about. 

Notice that Dreamweaver automatically checks the Preload Images checkbox in the insert 
rollover image dialog box? What does that mean, exactly? The browser is being instructed to wait 
until all the graphics for the Rollover have been downloaded before the Rollover functions. 

Animated GIFs can be set to play once, any number of times (2x, 3x, etc.) or loop indefinitely. If 
when you create your animated GIF files you set them to loop indefinitely, then leaving the 
Preload Images box checked will work just fine, as it did here. However, if you have your 
animated GIF play only one time, it will play when it’s preloaded and by the time your end user 
looks at your rollover it will no longer animate.  

 **** 
So the rule is this: leave Preload Images on for looping GIFs and uncheck Preload 

Images if your GIF is set to play only one time. 
**** 

Creating Pointer Rollovers 
This next exercise shows you how to create pointer Rollovers, Point Rollovers re-use one piece of 
artwork (in this example, the star) which follows the mouse as you move over each word. This 
type of Rollover involves making a Table to hold all the artwork in place. You’ll also get to use 
the Behavior’s feature, instead of the Insert Rollover Image button from the Insert Palette. 

1. View the finished file first. Open 
pointerfinal.html located in the html folder 
and press F12 to preview it inside a browser. 
Move your pointer over the text to see the star 
move from item to item. Return to 
Dreamweaver and close the file. You’re going 
to recreate this example from scratch. 

2. Open pointer.html in the html folder, which 
already contains an empty table with 4 rows 
and 2 columns. 

3. Click inside Cell A and select Insert>Image 
and select blank_p.gif. The object of this 
exercise is to insert the same blank_p.gif 
image in every location that the pointer will 
appear. Why? Because Rollovers require two images, the original state and the Rollover state. 
In this instance, the original state looks like nothing, because it is a transparent gif, which lets 
the background show through. 

4. Repeat this process three times, inserting the same blank_p.gif file inside Cells B,C and D. 

5. After you have inserted the blank_p.gif image into each cell, click on the top left cell, as 
shown below. Inside the Properties Inspector, give it the name blank1. It is essential that you 
assign a unique name to each image by selecting each instance of blank_p.gif and naming it 
respectively, blank1, blank2, blank3, blank4. Make sure that the appropriate blank_p.gif 
image is highlighted when you name each graphic. 
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In Exercise #3, Dreamweaver gave the Rollovers a name automatically. When you use the Swap 
Image Behavior, you have to give each image a unique name, or the Behavior will not work. 
Names in Dreamweaver (or HTML) cannot contain any spaces.  

6. Click in Cell E and choose 
Insert>Image, then browse to 
about_p.gif located in the images 
folder and click Select.  

7. While the about_p.gif image is 
selected, enter the name about inside 
the Properties Inspector. Note: Naming 
each image is essential to working 
with Rollovers in Dreamweaver. This 
is because JavaScript requires a unique 
name for each source graphic in order 
to perform Rollover functions. For this 
reason, you will need to add a unique 
name for every image that you insert 
into this table. 

8. Click in Cell F and choose Insert>Image and browse to ourrooms_p.gif. Inside the 
Properties Inspector, name the image rooms. Click in Cell G and choose Insert>Image and 
browse to reservations_p.gif. Inside the Properties Inspector, name the image reservations. 
Click in Cell H and choose Insert>Image and browse to services_p.gif Inside the Properties 
Inspector, name the image services. 

9. Click on about_p.gif (about the inn) to select it. Open the Behaviors window (if it isn't 
already open) by selecting Window>Behaviors (or use the shortcut key Shift+F3). 
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10. With the about_p.gif (about the inn) selected, click on the plus sign 
button in the Behaviors tab in (Design Palette); in the drop-down menu, 
select Swap Image. 

11. Make sure the blank1 image name is highlighted at the top.  

 

12. Click the Browse...button and select star.gif located in the images 
folder. Click OK.  

13. Next select ourrooms_p.gif and click on the plus sign button to select 
Swap Image. Select  blank2 inside the Images list and click on the 
Browse...button to locate star.gif. Repeat this process for reservations_p.gif, selecting 
blank3 and services_p.gif for blank4. 

14. Press F12 to preview in your browser. 

This exercise demonstrated the benefit of using a Table to hold together multiple graphics. It also 
reinforced the fact that you need two images for a Rollover-the original state and the Rollover 
state. In this instance, the original was a blank image. You must also remember to name the 
Rollovers in the Properties Inspector. 

Creating Multiple-Event Rollovers 
A multiple-event Rollover uses more than two pieces of artwork in the Swap Image Behavior. In 
this example, three different pieces of artwork change for every rollover. If that sounds 
complicated, that's because it is. Assembling this type of Rollover can be tedious, but not nearly 
as tedious as writing all the HTML and JavaScript from scratch. 

1. Open multiple_final html located in the html folder, and preview this finished exercise in 
your browser. Roll you mouse over each item in the list, and watch the room change.  

2. Open multiple.html located in the html folder. 
Future steps will refer to the various cells on the 
picture below. 

3. Click inside Cell A (row 1, column 1) and choose 
Insert>Image to browse to arts.gif located in the 
images folder, then click Select. In the 
Properties Inspector, name the image arts. 

4. Click inside Cell B (row 2, column 1) and choose 
Insert>Image to browse to classic.gif located in 
the images folder, then click Select. In the 
Properties Inspector, name the image classic. 
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5. Click inside Cell C (row 3, column 1) and choose Insert>Image to browse to garden.gif 

located in the images folder, then click Select. In the Properties Inspector, name the image 
garden. 

6. Click inside Cell D(row 4, column 1) and choose Insert>Image to browse to giant.gif 
located in the images folder, then click Select. In the Properties Inspector, name the image 
giant. 

7. Click inside Cell E (row 5, column 1) and choose Insert>Image to browse to lovers.gif 
located in the images folder, then click Select. In the Properties Inspector, name the image 
lovers. 

8. Click inside Cell F (row 6, column 1) and choose Insert>Image to browse to monterey.gif 
located in the images folder, then click Select. In the Properties Inspector, name the image 
monterey. 

9. Click inside Cell G (row 2, column 1) 
and choose Insert>Image to browse to 
mountain.gif located in the images 
folder, then click Select. In the 
Properties Inspector, name the image 
mountain. 

10. Click in the top right cell (Row 1, 
column 2) and choose Insert>Image to 
browse to blank1.gif located in the 
images folder, then click Select. In 
the Properties Inspector, name the 
image blank1. 

11. Click in the bottom right cell (Row 2, 
column 2) and choose Insert>Image to browse to blank2.gif located in the images folder, 
then click Select. In the Properties Inspector, name the image blank2. 

12. Select the image in Cell A (row 1, column 1). With the image selected, click the plus sign 
button in the Behaviors window to select Swap Image. Note: If the Behaviors window is 
not open, press F8 to open it. The Swap Image window will open. Be sure not to click OK 
until you are instructed to! Notice that arts is selected in the Images list. 

13. Click the Browse...button to Set Source to: arts_on.gif. This sets the Rollover for the 
graphic arts & crafts (arts.gif) to turn red when you move your mouse over it. Don’t click 
OK yet! 

14. Select blank1 from the same Images list. Click the Browse...button again to Set Sources 
to: arts.jpg. You just instructed the Behavior to swap the blank1 (blank1.gif) artwork to the 
picture of the arts & craft hotel room (arts.jpg).  The Rollover now triggers two Behaviors: 
the lettering for arts & crafts has been instructed to turn red, and an image of the room will 
appear when the mouse moves over the original image Don’t click OK YET! 

15. Scroll down the Images list to select blank2.  Click the Browse...button again to Set Source 
to : artstext.gif. YOU MAY NOW FINALLY CLICK OK TO END THIS PROCESS. 

16. At this point, stop and test your rollover in your browser by pressing F12. Move your mouse 
over the words arts & crafts The lettering should turn red, and a picture of the room should 
appear to the upper right, with its description below. You’ve just set the rollover for arts & 
crafts. There are six more items on the list to go. 

17. Return to Dreamweaver and repeat this process for the other images. Start with the Swap 
Image window in Step 12. Below is a chart that outlines the images to uses in each column. 
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Swap Images At A Glance 

Cell Images Set Source To 
B (row 2, column 1) classic.gif 

blank1 
blank2 

classic_on.gif 
classic.jpg 
classictext.gif 

C (row 3, column 1) 
garden.gif 
blank1 
blank2 

garden_on.gif 
garden.gif 
gardentext.gif 

D (row 4, column 1) giant.gif 
blank1 
blank2 

giant_on.gif 
giant.jpg 
gianttext.gif 

E (row 5, column 1) lovers.gif 
blank1 
blank2 

lovers_on.gif 
lovers.jpg 
loverstext.gif 

F (row 6,column 1) monterey.gif 
blank1 
blank2 

monterey_on.gif 
monterey.jpg 
montereytext.gif 

G (row 7, column 1) mountain.gif 
blank1 
blank2 

mountain_on.gif 
mountain.jpg 
mountaintext.gif 

Adding A Flash Button And An Email Hyperlink 
Now we are going to add a Contact button at the bottom of this page and attach an email 
hyperlink to it.  We are going to create a Flash button that will act like a rollover. 
1. Click on the 2nd column/4th row cell.  From the Insert Bar, select the Media tab and then 

click on the Insert Flash button icon (Figure 25). 

 
2. The Insert Flash Button dialog box appears (Figure 26).  From the Style: area, select 

Beveled Rect-Grey and the picture of the button type will show in the Sample: area. 
 

3. In the Button Text:  text box, type “Contact” 
4. From the Font: pull-down menu, select Lucida Handwriting (this is the font that was used 

for the navigational buttons). 
5. In the Size: box, type 16. 
6. In the Link: box, type mailto: and then after the colon, type your email address.  (DO NOT 

place a space between the colon and your email address. 
7. In the Save As: text box, it should say “button1.swf” (.swf is the Flash extension). 
8. Click the Apply button and then click the OK button. 
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9. Now click on the Contact button that was created and change the following properties in the 
Properties Inspector (Figure 27): Align=Absolute Middle, Scale=Exact file. 
 

 
 

10. Click on the Play button in the Flash Button Properties box and then drag your pointer over 
the Contact button to see it rollover.  Click the Stop button that appeared when you are 
finished testing it. 

11. Preview the page in your browser.  Try out the Flash button.  If Flash is not installed on your 
browser, a dialog box will appear asking if you would like to install the plugin.  Install the 
plugin and continue testing the page. 
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