
Dreamweaver MX - Templates And Libraries 

OBJECTIVES 
In this section you will learn to: 

• Creating and Modifying Templates 

• Creating and Modifying Library Items 

WEB DESIGN RESOURCES 
The Web Authoring Resouce Center (WARC) (http://www.calpoly.edu/warc/) provides developers 
of Cal Poly Official Web sites with the information and tools necessary to plan and build a site that meets 
basic requirements for University Identity, Web Accessibility, Usability, and Aesthetics. In addition, the 
WARC provides valuable information on how best to maintain web sites for currency and efficiency.  

The templates used in this class are available for download at the WARC website, 
http://www.calpoly.edu/warc/universityid/templates.html. 

INTRODUCTION 
Two of the biggest challenges that face Web designers are making pages look consistent, and updating 
changes throughout a site. Templates and Library Items can help you meet both of these challenges 
successfully, because they make it easy to create consistent pages and page elements and to automatically 
update multiple pages when changes are made. 

Templates are useful for entire page designs. They can lock in colors, fonts, tables, or images, while 
leaving other parts of the document editable. When you create a Template, you use it by requesting a copy 
of it. Instead of creating a new Untitled Document, you request a new page based on a Template that you 
have designed. 

Library Items are useful for page-design elements, such as a navigation bar or copyright notice. They are 
little pieces of HTML or text that can be dropped anywhere within a page. 

TEMPLATES AND LIBRARY FOLDERS 
You will notice that there are two folders inside your local root folder 
that are called Templates and Library. Dreamweaver automatically 
creates these folders for you on any site that uses Templates or 
Library Items. If you do not use Templates or Library Items, 
Dreamweaver will not put these folders in your directory structure.  

These folders (Templates and Library) do not need to be uploaded to 
your remote web site when you publish it to the Web. They are for 
internal purposes only. If Dreamweaver sees that these folders are 
present in your directory structure, it knows to insert any new 
Templates or Library Items that you create into the appropriate folder. 
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CREATING A NEW TEMPLATE 
In this first exercise, you are going to create a new Template from an existing document and then make 
parts of your Template editable and other parts non-editable. 

 
1. Open page1.html. This document was created for you, but the following steps would also work on a 

document of your own creation. Once you have created the basic layout of your documents, the next 
step is to save it as a Template. 

2. Choose File>Save as Template. 

You will receive a message that the template does not have 
editable regions. Editable regions provide a way for you to 
allow or restrict access to specific areas of a page based on 
template.  

3. Click the OK button. 

 

 

4. When the Save As Template dialog box opens, change the 
name to say cptemplate. Click the Save button. 

 

 

5. You will know that you are working with a Template 
because the title bar displays <<Template>> and the 
filename ends with a .dwt extension. 
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Now that you have created your Template, you need to decide which areas you want to be able to 
modify and which areas you want to lock. By default, the entire document is designated as locked or 
non-editable. This means if you were to close the file now, it would be impossible for anyone to 
modify pages created from the Template. 

6. Before you proceed, turn on the option to display Invisible Elements. From the View menu, select 
Visual Aids > Invisible Elements. 

The little yellow “shields” you see are Comment markers that the page designer included to explain 
the code or provide other information. 

7. On the open cptemplate, select the > character next to 
the word Home. Choose Insert > Template Object > 
Editable Region… to designate this area as an editable 
region so that you or other members of your team can 
enter the page information.  

8. When the New Editable Region dialog box appears, enter breadcrumb and click OK. 

Notice that a box with blue borders appears around the text that you selected with the name of the 
editable region above. This indicates that this area of the Template is editable . 
• A breadcrumb is like a "You Are Here" indicator within your Web site.  

• A breadcrumb reflects the most common path from your home page to the page currently being 
displayed.  

• Note: the Editable Regions are viewable (blue boxes) because we turned on the Invisible 
Elements in a previous step. Being able to see these areas on the page may be distracting but they 
make editing much easier. 

9. Click inside the large cell that contains the Page Title. Now, in the Tag Selector, click the last 
<table> tag. Notice the black border and handles that surround the cell that contains the Page Title.  

 

TIP: The Tag Selector in the status bar at the bottom of the Document window shows the hierarchy of 
tags surrounding the current selection in Design view. Click any tag in the hierarchy to select that tag and 
all its contents. 
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10. Choose Insert> Template Object > Editable Region…when the New Editable Region dialog box 
appears, type page content and click OK.  

11. Scroll down so that you can see the text “Last Updated: mm/dd/yyyy” in the lower left corner of the 
page. 

12. Position the cursor to the left of the text “mm/dd/yyyy.” 

13. From the Insert menu, select Template Objects > Editable 
Regions.  

14. Type Date for the name of the Editable Region. Click the 
OK button. 

15. Place your cursor in the the blue box of the Editable Region.  

16. From the Insert menu, select Date. 

17. Select the Date format you prefer and place a checkmark in 
the box next to Update Automatically on Save. 

18. Delete the word “Date” in the Editable Region and delete 
the text “mm/dd/yyyy” outside and to the right of the Editable Region. 

Your page should look like this: 

 

Modify The Page Title 
Each page needs to have a Page Title to disquish it from other pages in your site. When someone views a 
page in your site the Page Title appears in the Browser Title Bar and if they “bookmark” the page the 
Page Title is what appears in their Bookmarks or Favorites list. 

1. With the template still open, from the Modify menu, select Page Properties. 

The Title field shows “Page Title - Department - Cal Poly.” 
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2. Double-click on the word “Department” and change it to your department name. 

You won’t change the Page Title in the Template, instead you will use these same steps to change the 
Page Title on each page. 

3. Close the Template file. When prompted, make sure that you Save your changes.  

You have just created a custom template. Next, you will create a page based on your newly created 
Template. 

CREATE A NEW PAGE BASED ON A TEMPLATE 
1. From the File menu choose New From Template. If necessary select the Templates tab. 

2. Highlight cptemplate in the list and click the Create button. This will create a new document based 
on the Template. 

3. From the File menu choose Save As…and save the file as 
index.html into your site folder. 

Your page will look just like the picture of the Template shown 
above however you will see the name of the template in light 
yellow in the upper right corner of the page. 

TIP: DON’T SEE ANY EDITABLE REGIONS OR THE TEMPLATE NAME?  

If you don’t see the Editable Regions on your screen, make sure that you have the Invisible Elements 
option enabled. If you disable this feature, you will not see any highlighting. To turn this option on you 
can choose View>Visible Aids>Invisible Elements to enable/disable this feature. 

4. Highlight the > next to the word “Home” and press Delete. 

5. Highlight the text “Page Title” and press Delete and type: WELCOME TO… Our department 
website. 

6. Save and keep this file open.  

7. Repeat the previous steps to create a another page based on the template and save the file as 
page1.html.  

8. When prompted to overwrite the existing file, click the Yes button. 

9. Close all open files. If prompted, click the Yes button to Save the files. 

MODIFYING A TEMPLATE 
Now that you have created your first Template, you are ready to learn how to update it. In this exercise, 
you are going to change the Department Name in the heading area, designate the Home link, and modify 
links in the Menu Bar and Text Navigation Bar.  

1. You must open a template to modify it. Double-click the cptemplate file in the Templates palette to 
open your template. 

2. Now that the template file is open, highlight the text “Department Name” and change the name to 
your department name. 

3. Select the word Home in the “breadcrumb” Editable Region. 
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4. Position the cursor in the Properties Inspector in the Links box. 

5. Click the yellow folder to the right of this box and select the index.html page.  

6. Click the OK button. 

Working With The Menu Bar And Navigation Links 
We also need to modify the Menu Bar and create links to the various pages in our site. The most common 
navigation is to place links along the left side of the page and content in the middle to right side. That’s 
what our template uses.  

Many sites use graphics in the Menu Bar with Rollover effects. This makes for a snazzy site but for many 
of us, creation of graphics is that the easiest thing to do. Our Template uses Text in the Menu Bar. Text is 
much easier to edit and we can also simulate Rollover effects with settings in the Page Properties that 
control the link effects.  

You will also create Text Links at the bottom of the page that mimic the links in the Menu Bar.  

Creating Page Links 
1. Select Sample Link 1 in the Menu Bar. 

2. Position the cursor in the Properties Inspector in the Links box. 

3. Click the yellow folder to the right of this box and select the page1.html page.  

4. Click the OK button. 

5. Select the Sample Link 1 in the Text Navigation bar at the bottom of the page. 

6. Position the cursor in the Properties Inspector in the Links box. 

7. Click the yellow folder to the right of this box and select the page1.html page.  

8. Click the OK button. 

9. Now that you have designated the necessary areas as editable, Close this file. When prompted, make 
sure that you Save your changes. 

10. Close the Template file. When prompted, make sure that you Save your changes.  

11. A dialog box will appear, asking if you wish to update the files in your site which use this Template. 
Click the Update button.  

12. Click the Close button. 

13. Save and close all open files. 
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CREATING A LIBRARY ITEM 
Library Items and Templates are somewhat similar in function. 
Both are used to apply changes to multiple pages with ease. The 
difference is that Templates affect the entire page design, while 
Library Items are used for individual page elements.  

In this exercise, you will create a copyright notice. You will then 
apply it to the template by simply dragging it onto a page. 

1. Open the copyright.html page. 

2. Select all of the text that appears on this page. 

3. In the Files Panel Group, open the Assets Panel and select 
the Library category. 

4. In the Library category, click the New Library Item icon. 
Your new Library Item will instantly appear in the palette. It 
needs a name, so type copyright. 

5. Now that you have created your Library Item, you can apply it to a page. Create a new blank 
document by choosing File>New. Then Choose File>Save and save this file inside your site folder as 
mypage1.html. 

6. In the Library palette, highlight the copyright Library Item and choose Add to Page from the 
Library palette’s pop-up menu. 

The Library item is applied to the page. 

7. Save mypage1.html and leave it open. Leave copyright.html open as well. 

MODIFYING A LIBRARY ITEM 
Now that you know how to create a Library Item, you are going to modify the one you just created and 
then watch Dreamweaver quickly update your page.  

1. With copyright.html and mypage1.html open and copyright highlighted in the Library palette from 
the last exercise, click the Edit  icon. This will open the Library Item for editing. 

2. Position the cursor at the end of the line. Type All Rights Reserved.  

3. Close this file, and when you are prompted, make sure you Save and update your changes. 

4. Check that the change occurred on the mypage1.html. 

5. Look at the copyright.html page. Notice that the text has a yellow background. This text is now 
controled by changes made to the copyright.lbi library item. 

6. Close all documents and Save your changes. 
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