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 Class 6 – 

Excel and nVision

Freeze Panes, Split Screen, Filtering, Comments and Subtotals

Given the fact that we will be working with static information we will not be able to do drill down into the data. The files that we will be using are snapshots of the real information. You can change this information without causing any changes to take place in the real data. When ever you use nVision to look at information you are looking at a snapshot of that information. If you make changes to that data and you save your changes, those changes will only be in the saved in the file you have edited and not in the original data used to create the nVision file.

Open the worksheet- Management Summary Report by Department
1) Start Excel

2) Go to File Open [image: image22.wmf] 

 icon on your standard toolbar

3) Select the file Management Summary Report by Department
4) Enable Macros

5) Scroll down and across the worksheet and notice that the column and row heads scroll off the screen making it difficult to view the information.

Freeze Panes 

Freeze Panes helps to keep row and column labels visible as you scroll on the worksheet

1) To keep row and column labels or other data visible as you scroll through a sheet, you can "freeze" the top rows and/or left columns. The frozen rows and columns don't scroll but remain visible as you move through the rest of the worksheet.

2) To freeze the top horizontal pane, select the row below where you want the split to appear. 

a) Select cell B19

b) Go to the Window menu, select Freeze Panes
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To freeze the left vertical pane, select the column to the right of where you want the split to appear. 

c) First we must unfreeze the previous freezing of the panes by going to the Windows menu and selecting Unfreeze Panes

d) Then select cell E2

e) Go to Windows and Freeze Panes

3) To freeze both the upper and left panes, click the cell below and to the right of where you want the split to appear. 

a) First unfreeze the previous freezing of the panes

b) Select cell E19

c) When you are done experimenting with Freeze Panes go to the Windows Menu and select Unfreeze Panes.

Split Screen

Split a worksheet to view two parts of a sheet at the same. To view and scroll independently in different parts of a worksheet, you can split a worksheet horizontally and vertically into separate panes. 

Splitting a worksheet into panes allows you to view different parts of the same worksheet side by side and is useful, for example, when you want to paste data between different areas of a large worksheet. 

	At the top of the vertical scroll bar or at the right end of the horizontal scroll bar, point to the split box.
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	When the pointer changes to a split pointer, drag the split box down or to the left to the position you want.
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To restore a window split into two scrollable areas, double-click any part of the split bar that divides the panes. 

You cannot split a worksheet and freeze parts of a worksheet at the same time.

· Experiment with splitting the screen in half horizontally and vertically then experiment with cutting and pasting data.

· When you are done with your experimentation go to Window then down to Remove Splits

Hide Columns and Rows

When you hide parts of a workbook, the data is removed from view but is not deleted from the workbook. If you save and close the workbook, the hidden data remains hidden the next time the workbook is opened. If you print the workbook, Microsoft Excel does not print the hidden parts.

You can hide workbooks and sheets to reduce the number of windows and sheets on the screen and to prevent unwanted changes. For example, you can hide sheets that contain sensitive data.

You can also hide selected rows and columns of data that you aren't using or that you don't want others to see. To prevent others from displaying hidden sheets, rows, or columns, you can protect the workbook or sheet with a password.

You can hide most window elements in order to use as much of your screen as possible to display worksheet data. These window elements include the Windows taskbar and the Excel title bar, toolbars, formula bar, and status bar. These elements remain hidden only as long as the workbook is open; they are redisplayed when you close the workbook and open it again.

To hide a row or column-

1) To hide a worksheet you will select the worksheet you want to hide

a) Go to the Format menu then down to Sheet then Hide

b) If you select multiple sheets you can hide them all at one time

2) To hide a row or a column

a) On the Format menu, point to either Row or Column, and then click Hide

3) To unhide the hidden rows or columns 

a) Select the rows or columns on either side of the hidden rows and columns the go to the Format menu and unhide them
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Note:

Some areas of the worksheet contain formulas and other areas are just populated with information that comes from the base data.

This makes it possible for you to change the data and see the results of your changes. For example the Year - to - Date balances are formulas. You can tell that it is a formula because if you click on one of the cells in that column you can see the formula in the formula bar. If you change some of the information in the other cells it will change this total. You may want to do this if you are doing some estimations or projections.

[image: image20.png]B3 Microsoft Excel
|E] Fle Edt View Insert Format Tools Data Window Help Acrobat

DzEa8RY s RBS | o-=-[@= 4 8 @ew -0,

[ o spzu===Hs %, 94 [E-o-A-
G4
T203] [ C [ D [ E T FTJ G | H

2
3
4 PO Reg D PO Date _Period_Status [Vendor Name 1 VendoriD
5 12001200136 2001-07-02 2 C  CDW GOVT INC 0000000469
6 12001200136 2001-07-02 2 C  CDW GOVT INC 0000000469
7 12001200136 2001-07-02 2 C  CDW GOVT INC 0000000469
8 12001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
9 12001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
102001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
112001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
122001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
132001200136 2001100122 2001-07-02 4 C  CDW GOVT INC 0000000469
142001200136 2001100122 2001-07-02 1 C  CDW GOVT INC 0000000469
152001200136 2001100122 2001-07-02 1 € CDW GOVT INC 0000000469
16 CDW GOVT INC Total
17 12001200209 2001-07-10 2 D ADVANCED OFC AUTOMATION 0000000413
18 /2001200209 2001-07-10 2 D ADVANCED OFC AUTOMATION 0000000413
192001200209 2001-07-10 2 D ADVANCED OFC AUTOMATION 0000000413
20| 2001200209 2001-07-10 2 D ADVANCED OFC AUTOMATION 0000000413
212001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
222001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
232001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
242001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
252001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
26 | 2001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
27 |2001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
28 | 2001200209 2001100069 2001-07-10 1 D ADVANCED OFC AUTOMATION 0000000413
23 ADVANCED OFC AUTOMATION Total
30 /2001201023 2001-08-14 C  HARDY DIAGNOSTICS 0000000140
312001201023 2001-08-14 4 C  HARDY DIAGNOSTICS 0000000140

4> pAPD T




[image: image21.png]


[image: image7.png]E3 Microsoft Excel - Management Summary Rpt by Dept for 117500.xls

@) Ele Ed Yow Iert Formet Tods Dota Window o Acopet

D

FHAERY 4 BRS o - (@ f-mmgfm =@

| aria rruls==E(s%, B
Kig (18-(18+/16)
| 5 e T F [ & [ " T T CSm—

z

a

4 Management Summary Report by Department

5 For Year to Date through 2001.09.30 (=

& For: 117500 - College of Science & Math

7| un Date and Time: 0WIG/2002 11226

(

s Current Period Year - To - Date

et

| Funa | pept Description Budget actuals  |Encumbrances|  Buget actuals _ |Encumbrances|  Balance )
[P0 17500 | CSM Colege ofSisno . Mt 25000 w2s2000
| Mpoos TF-CG CSUPERD 000 000 000 o szsz000 X 262000
T [V025 T CSM Collge ofSienor s M ) E
{25 TS0 G Aing Contr ) @son) zam
5 |Mxoz9 TE-MT Hith Pro Letter Fee X o0 X 000 z54.00) X 00
5 {1037 TR Cakinesiloay (s5500) [
| Mxo37 TF-MT Laundry Oper & Replac 000 000 000 000 50.00) 000 500
w[dh  TotalRevenues 000 @14.00) 000 000 (8337200) 000 [B3372.00
B [ADZ U CoMBomgeusnees P Er B P T T )





Comments

You can attach notes to cells by using comments.

You can view each comment when you rest the pointer over the cell or view all comments at the same time. You can print comments in the same locations where they appear on the worksheet or in a list at the end of the worksheet.

To add a comment to a cell

1. Click the cell to which you want to add the comment.

2. On the Insert menu, click Comment.

3. In the box, type the comment text.

a. Note the default name that shows up in the box

b. This name is associated with your User Information

c. To change user information

i. Go to the Menu Bar -> Select Tools -> Go down to Options

ii. On the Options Menu -> select User-> Edit this information

4. When you finish typing the text, click outside the comment box. 

5. You should now see a little red triangle in the upper right hand corner of the cell

6. When you place your cursor on the little red triangle the comment will pop up.

Notes 

· When you sort items on a worksheet, the comments move to new positions with the items in the sorted rows or columns.

· Comments in PivotTables remain anchored to the cells where you entered them, not to the cell contents. If you pivot the table or make other changes that affect the layout, the comments do not move.  

· If you click a cell and then press DELETE or BACKSPACE, Microsoft Excel removes the cell contents but does not remove any comments or cell formats.

· If you clear a cell, Microsoft Excel removes the contents, formats, comments, or all three from a cell. The value of a cleared cell is 0 (zero), and a formula that refers to that cell will receive a value of 0. 

· To remove all comments from a worksheet, click Go To on the Edit menu, click Special, and then click Comments. Then point to Clear on the Edit menu, and click Comments.

· To hide or display comments and their indicators -> On the Tools menu, click Options, and then click the View tab.

· To hide comments, even when you rest the pointer over the cells that contain them, and also clear the comment indicators from the upper-right corners of the cells with comments, click None under Comments. 

· To display comments when you rest the pointer over cells that contain them, and also show the comment indicators, click Comment indicator only. 

· To display both comments and indicators regardless of the mouse position, click Comments & indicator. 

· You can hide an individual comment by right-clicking the cell that contains it, and then clicking Hide Comment. When you want to display all individually hidden comments, click Comments on the View menu. 

· If you will be adding many comments to a worksheet you may want to use the Reviewing Toolbar. To get the Reviewing Toolbar –Go to the View menu then down to Toolbars then select Reviewing
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· When using the Reviewing Toolbar you can create, edit and view one or many comments.

Filtering 
Open the file LinearDrill_PO.xls
Filtering is a quick and easy way to find and work with a subset of data in a list. A filtered list displays only the rows that meet the criteria you specify for a column. 

Microsoft Excel has a number of features that make it easy to manage and analyze data in a list. To take advantage of these features, enter data in a list according to the following guidelines.

· Put similar items in one column. Design the list so that all rows have similar items in the same column.

· Keep the list separate. Leave at least one blank column and one blank row between the list and other data on the worksheet. Excel can then more easily detect and select the list when you sort, filter, or insert automatic subtotals.

· Show rows and columns. Make sure any hidden rows or columns are displayed before making changes to the list. When rows and columns in a list are not showing, data can be deleted inadvertently.

· Use formatted column labels. Create column labels in the first row of the list. Excel uses the labels to create reports and to find and organize data. Use a font, alignment, format, pattern, border, or capitalization style for column labels that is different from the format you assign to the data in the list. Format the cells as text before you type the column labels.

· Use cell borders. When you want to separate labels from data, use cell borders not blank rows or dashed lines to insert lines below the labels. Use the Border shortcut to create borders. It is on the formatting toolbar and looks like this-   [image: image9.png]


 

· Avoid blank rows and columns. Avoid putting blank rows and columns in the list so that Excel can more easily detect and select the list.

· Don't type leading or trailing spaces. Extra spaces at the beginning or end of a cell affect sorting and searching. Instead of typing spaces, indent the text within the cell.

· To indent text from the left edge of a cell

· Select the cells that contain text you want to indent.

· On the Formatting toolbar, click Increase Indent  
. 

· To decrease or remove indentation, click Decrease Indent  
. 

· When you add new rows of data to the end of a list, Excel uses consistent formatting and formulas. Three of the five preceding cells must use the same format or formula for this to occur.
· To turn on or off extended formats and formulas
· When you turn on extended formats and formulas, Microsoft Excel automatically formats new data that you type at the end of a list to match the preceding rows and automatically copies formulas that repeat in every row. To be extended, formats and formulas must appear in at least three of the five list rows preceding the new row.

· On the Tools menu, click Options, and then click the Edit tab.

· Do one of the following: 

· To automatically format new items that you add to the end of a list to match the format of the rest of the list, select the Extend list formats and formulas check box. To prevent automatic formatting, clear the check box. 

Filtering

Microsoft Excel provides two commands for filtering lists: 

· AutoFilter, which includes filter by selection, for simple criteria

· Advanced Filter, for more complex criteria 

Unlike sorting, filtering does not rearrange a list. Filtering temporarily hides rows you do not want displayed. When Excel filters rows, you can edit, format, chart, and print your list subset without rearranging or moving it.

Auto Filter

Make sure you have the file LinearDrill_PO.xls open

Go to Data on the menu bar then down to Filter then select Auto Filter
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When you use the AutoFilter command, AutoFilter arrows appear to the right of the column labels in the filtered list. 

[image: image13.png]i i g

e [ ¢ [ D E F G
2|
3
4 [ PO <] ReqlD < PO Datix] Perio~] Stattx|Vendor Name
5 (2001200136 010702 2 € COW GOVT INC
6 |2001200136 0010702 2 C  COWGOVTINC
7 |2001200136 010702 2 C  COWGOVTINC
o B ~

AR AT TN~





Clicking an AutoFilter arrow displays a list of all unique, visible items in the column, including blanks (all spaces) and nonblanks. By selecting an item from a list for a specific column, you can instantly hide all rows that don't contain the selected value.

If you are filtering a list of numbers, you can quickly view the largest values in the list by clicking the Top 10 item in the AutoFilter list. To resume viewing everything in the column, click All. 

Viewing a filtered list –

· Microsoft Excel indicates the filtered items with some visual cues. In this example, the AutoFilter arrow in the column that has a selected value is blue. The filtered row numbers are also blue.

To find all records from the VendorName LIFELINE

1) Make sure you have selected AutoFilter

2) Click the little downward pointing arrow next to the column heading Vendor Name
3) Choose LIFELINE from the drop down box
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4) To turn off this AutoFilter go to the drop down arrow next to the column header Vendor Name and select All.




 CONTROL Internet.HHCtrl.1 Custom AutoFilter

1) To find specific values in rows in a list by using one or two comparison criteria for the same column, point to Filter on the Data menu, click AutoFilter, click the arrow in the column that contains the data you want to compare, and then click Custom. 

2) To match one criterion, click the comparison operator you want to use in the first box under Show rows where, and then enter the value you want to match in the box immediately to the right of the comparison operator.

3) To display rows that meet two conditions, enter the comparison operator and value you want, and then click the And button. In the second comparison operator and value boxes, enter the operator and value you want.

4) To display rows that meet either one condition or another condition, enter the comparison operator and value you want, and then click the Or button. In the second comparison operator and value boxes, enter the operator and value you want. 

Using Custom AutoFilter

1) Select the drop down arrow to the right of the column header  Monetary Amount
2) Go down to Custom

3) The Custom Filter dialog box pops up
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4) Click on the drop down arrow to the right of the word equal

5) Select “Is greater than”

6) In the box to the left enter 1000

7) Click OK

8) You should now see only the records that had a value of more than 1000.

Subtotals

Microsoft Excel can automatically summarize data by calculating subtotal and grand total values in a list. To use automatic subtotals, your list must contain labeled columns and the list must be sorted on the columns for which you want subtotals.

When you insert automatic subtotals, Excel outlines the list by grouping detail rows with each associated subtotal row, and grouping subtotal rows with the grand total row.

You can choose the function for Excel to use when it calculates totals. 

Open the file LinearDrill_PO.xls

In this exercise you will create subtotals for the total dollar amount for each Vendor.

1) Sort the spreadsheet by Vendor Name.

a) Click on the column header “Vendor Name”

b) Click the sort button  [image: image16.bmp]
2) Subtotal based upon Vendor Name.

a) Go to Data on the main menu then down to Subtotal
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3) The Subtotal Dialog box
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a) In the “At each change in;” drop down select Vendor Name

b) “Use function “choose Sum

c) “Add subtotal to:” check Monetary Amount

d) Check – Replace current subtotals

e) Check – Summary below data

4) Expand and compact outline levels.

a) Outline levels can be seen to the left of the spreadsheet.
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