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Introduction 
 
This tutorial will address three ways to place video into your PowerPoint files. Each method has 
its advantages and disadvantages but it is important to be aware of the issues so you can 
choose the method that will work best for your particular situation.  
 

1. The first way is to simply “embed” the video by using the Insert menu method to add 
the video to your PowerPoint. This method may work for you if the video is small (less 
than 2 minutes) and you don’t plan to move the PowerPoint to a different computer or 
have it downloaded from the web or Blackboard.  

 
2. The second way is to create an Action Button to play the video from PowerPoint but in 

this method PowerPoint will use a hyperlink from the Action Button to navigate via a 
path you have specified to find the video on your computer and then play the video in 
the application that was designed to play it (e.g., Windows Media Player, QuickTime, Real 
Player, Flash, etc.). This method is a better choice for longer videos (over 2 minutes) and 
if you plan to move the PowerPoint to a different computer (e.g., from your home 
computer to your laptop). This method is also preferable to embedding because it 
allows Windows PowerPoint users to use any form of video that their computer has the 
software to play (i.e., QuickTime, Real Player, etc.) Since Windows XP, Windows users 
have not been allowed to embed anything but Windows Media Player (.wmv) and Audio 
Video Interweave (.avi) files. 
 

3. The third way is to have the video placed on the QuickTime streaming server in Media 
Distribution Services (Bldg. 2, Room 9) and access the video through your PowerPoint via 
a hyperlink to the streamed video. This method is best for longer videos (above 2 
minutes) and insures a quick download for users with even the slowest connection 
because the video is buffered so the user receives only what they need to play the video. 
It is also preferable for video that might have copyright issues, since the user does not 
download anything to the computer and will not be able to keep the video. 

 
Let’s look at the steps involved in utilizing the various methods: 
 

 
Embedding a Video File 
 
PowerPoint allows you to “insert” a video to play within your presentation -- this process is 
called embedding the video because it (supposedly) embeds the video to be a part of the 
PowerPoint no matter where you move the PowerPoint from location to location. However, we 
have found that this to not necessarily true and sometimes when you embed a video, you will 
find later when you move to another computer, that the video no longer plays properly. If you 
choose add a video via this method, be careful to select short videos because a video within 
your PowerPoint can greatly increase the PowerPoint’s size. What’s the problem with that you 
ask? If you place your PowerPoint on the web or within Blackboard, a larger-size PowerPoint can 
greatly increase download time for the user; it can also result in potential problems in general 
for simply running the PowerPoint on your computer during a presentation.  
 

1. To embed a video, go to Insert > Movies and Sounds > Movie from File… and 
navigate to your video on your computer and select it. 
 

2. PowerPoint will bring up a dialog box asking: “How do you want the sound to start in 
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the slide show?” with the options of Automatically or When Clicked. Select whichever 
you desire. 

 
3. Note that Windows PowerPoint 2003 is very restrictive on the movie formats it will 

accept for insertion (only .wmv or .avi – no QuickTime or Real Player).  
4. PowerPoint will insert the movie and place the image of the first frame on the 

PowerPoint. 
 

5. Right-click on the movie and select Edit Movie Object and select the checkbox next to 
Rewind movie when done playing. This is also where you may select to loop your 
movie or to have it zoom to full screen. Click OK to close the Movie Options dialog 
box. 

 
6. If you wish, you can place a border around your movie by right-clicking and selecting 

Format Picture and then using the Color and Lines tab to set a border as you would for 
an image. A border of 6-9 pts. is generally recommended. 

 
7. Your movie will play when you view it in Slide Show View (i.e., select Slide Show > View 

Show). However, if you wish to play it in normal slide view, you can right-click upon it 
and select Play Movie. 

 
 

 
Windows Package for CD Feature 
 
If you’re a Windows PowerPoint 2003 user and you choose to embed your video but decide to 
later move it to another computer, be sure to use PowerPoint’s Package for CD feature (sorry, 
this feature is not currently available within the Macintosh version of PowerPoint).  This cool 
new feature in PowerPoint 2003 provides you with the ability to save your PowerPoint 2003 
presentation to a CD or to a folder that you place on a Flash drive or zip disk and take it with 
you anywhere. And guess what? When you take it “anywhere,” you won’t need PowerPoint 2003 
to show the presentation! When the package is created it includes the PowerPoint Viewer that 
will show your PowerPoint, regardless of the computer you’re using! And if you have ever had 
problems with pesky fonts not appearing on a different computer, this is a great feature 
because it actually embeds the True Type fonts in the PowerPoint so it looks like you intended 
it to no matter where it displays. 
 

1. To use this feature, choose File > Package for CD. The Package for CD dialog box will 
appear. This Package for CD dialog box will allow you to package the presentation in 
order to copy it to a folder or directly to a CD-ROM (if your CD creation program allows 
for this). 

 
2. Type a name for the CD in the text box next to Name the CD or click on the Copy to 

Folder button in this dialog box and type a name for the folder (PowerPoint will create 
the folder for you on your Desktop).  
 

3. Click on the Options… button to bring up the Options dialog box.  Study the options and 
change any that aren’t set the way you desire: 
 

• PowerPoint Viewer: Check this option to include the PowerPoint Viewer on the 
CD. This allows you to play your presentation on computers that don’t have 
PowerPoint already installed upon them. 

 
• Linked files: Check this option to include any linked files (such as videos or large 

audio files). 
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• Embedded TrueType fonts: Check this option to ensure that the fonts you used 

in your presentation will be available to you when you show the presentation on 
another computer. 

 
• Password to open each file: Enter a password if the presentation contains top-

secret information. 
 

• Password to modify each file: Enter a password if you want to prevent 
unauthorized people from changing the presentation. 

 
4. Click OK to return to the Package CD dialog box. 

 
5. If you want to add other presentations to the CD, click the Add Files… button and select 

the files that you wish to add and then click Add. 
 

6. Click on either the Copy to CD button or on the Copy to Folder button. If you click on 
the Copy to CD button, the computer will ask you to place a CD in the CD-ROM drive. If 
you selected Copy to Folder, PowerPoint will ask you to select the location where you 
wish to place the folder. It is usually easiest to save it to the Desktop but you can also 
save the folder to somewhere on your C: drive. 
 

7. When you have settled on your selections, click OK. After you click OK, your computer 
will process the files for a few minutes and then return to the Package for CD dialog 
box. When this occurs, simply click the Close button and the menu screen will go away. 
 

8. If you burned the files to CD, click on the CD icon and review the files within it. If you 
copied it to a folder, go to the C: drive or Desktop where you saved your folder. Double-
click quickly on the folder to open it. When your folder opens, you will be able to see the 
files created by PowerPoint Package CD. You could also burn this folder to a CD or place 
it on a Flash drive or zip disk for portability. If you go to another computer that has 
PowerPoint 2003, your PowerPoint presentation will be available to you. Even if the 
computer does not have PowerPoint 2003 installed, you can use the pptview.exe file to 
show your presentation if you chose to include the PowerPoint Viewer when you 
selected your options earlier. 

 

 

Creating an Action Button to Point to a Video 
 
Before you begin the process of creating an Action Button, right-click and make a new folder. 
Place your PowerPoint in this new folder and move the video you wish to point to from the 
PowerPoint into this folder as well. By placing both the PowerPoint and video within the same 
folder, you will lessen the chances for the hyperlink to be broken as you move the PowerPoint 
from computer to computer. If you choose to move the PowerPoint to a different computer 
later, take the entire folder with you so that the hyperlink remains valid and so you don’t forget 
to take the video with you. Follow the instructions below to create an Action Button: 
 

1. Open the PowerPoint from within the folder location by double-clicking upon it. 
 

2. Select Slide Show > Action Buttons > Movie (PC users: select the Movie icon). 
 

3. Click on the Mouse Click tab. 
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4. Your cursor will change into a plus sign. Use it to draw the desired size of your Action 
Button with your mouse. 
 

5. Choose the radio button next to Hyperlink to… and select Other File… from the pull-
down list. 
 

6. Navigate to the video on your computer and click OK. 
 

7. Click OK once more to close the dialog box. 
 

8. Try it out in Slide Show > View Show by clicking on the movie icon Action Button you 
created (Note: PC users may have to click twice). 
 

9. PowerPoint should open the video in whatever software application it was designed to 
play in and will begin playing the video. After the video plays, simply return to your 
PowerPoint to continue with your presentation. 

 
 

 

Hyperlinking to a Streamed Video  
 
The third method, hyperlinking to the video on Cal Poly’s QuickTime Streaming Server is the 
BEST way to play large videos from a PowerPoint presentation. This method will allow for 
immediate play (after a short buffer period), and not increase the size of the PowerPoint. 
However, remember if you use this method you must always have an Internet connection to 
view the video (something to be aware of if you plan to present the PowerPoint video at a 
conference room that doesn’t have an Internet connection.  
 
Your video must be formatted as QuickTime format (.mov) to be placed on the QuickTime 
Streaming Server. If it is not in this format, the staff at Media Distribution Services (MDS) in 
Bldg. 2, Room 9 will assist you in reformatting the video. 
 
Before you walk over to MDS, open your browser and visit: 
http://www.mds.calpoly.edu/mds_videoservices/encoding_streaming.htm in order to gain more 
information on the entire streaming process and what is required of you. Then, visit 
http://www.mds.calpoly.edu/mds_videoservices/forms.htm and download one of the “Encoding 
and Streaming” forms as a PDF. Print it and fill it out with a pen and take it with you to MDS 
with your video.  
 
Each department has an allotted amount of space on the QuickTime Streaming Server. MDS will 
create an account for you within your department’s directory on the server where your video 
will be uploaded. Once MDS has reformatted and encoded your video and uploaded it to the 
server, they will send you the link to your streamed video in an email. Once you have the link 
address, you can simply point to the streamed video from your PowerPoint with a simple 
hyperlink. Here’s how to create the hyperlink: 

 
1. Copy the link from the email that MDS sent you by highlighting the link and selecting 

Ctrl-C (PC) or Command-C (Mac). 
 

2. Open your PowerPoint and navigate to the slide where you wish to place the video link. 
 

3. Paste the link into any text box in PowerPoint (Ctrl-V (PC) or Command-V (Mac)). 
 

4. Drag across the entire link with your mouse to highlight it. 
 

http://www.mds.calpoly.edu/mds_videoservices/encoding_streaming.htm
http://www.mds.calpoly.edu/mds_videoservices/forms.htm
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5. Go to Insert > Hyperlink. When the Insert Hyperlink dialog box appears you will see the 
name of the link listed where it says Text to Display (PC) or where it says Display 
(Mac). 
 

6. Place your cursor in the Address box (PC) or Link box (Mac) and paste the link once 
more by using Ctrl-V (PC) or Command-V (Mac). 
 

7. Click the OK button to close the dialog box. 
 

8. The link will only work in Slide Show View mode. Go to Slide Show > View Show and 
test it out. PowerPoint should immediately open your default browser and begin 
buffering and playing the streamed video. 

 
 
Adding Music to Your PowerPoint 
 
Just as there are several methods for adding video to your PowerPoint, there are several ways 
that you can add music or sound to your PowerPoint presentation:  
 

1. You can insert (embed) music or sounds that play automatically when you display a 
particular slide or once you click on a sound icon on a particular slide. 

2. You can create an Action Button to hyperlink to a sound file such as an .aif, .wav, .mid, 
.mp3, etc. (Please see the instructions above for creating an Action Button to a video 
file.) 

3. You can have music that plays during one or during multiple slides and provide an 
indication to PowerPoint of when to turn off the music by setting the Effect Options in 
Custom Animation. 

4. You can insert a music CD into your CD-ROM drive and have PowerPoint play the CD 
from the track you designate until a specified track and time on the CD. 
 

 
Embedding a Sound or Music File 
 
Embedding a sound or music is the simplest way to place music into your PowerPoint but may 
result in problems as the video did when moving a PowerPoint from one computer to another. 
To embed a sound or music: 
 

1. Navigate to the slide in your PowerPoint where you wish to place the sound/music file. 
 

2. From the Insert menu, select Movies and Sounds > Sound from File… [If you want to 
insert a sound clip from Microsoft’s sound files, select Sound from Clip Organizer (PC) 
or Sound from Gallery (Mac).] 
 

3. Locate the folder that contains the music/sound file you want and then double-click the 
file. 
 

4. A dialog box will appear asking if you want to play the music/sound Automatically or 
When Clicked. If you choose Automatically, the music/sound will begin playing as soon 
as you get to the slide in Slide Show View; if you choose to have it play When Clicked, 
then the music/sound will only play when you click upon the sound icon. 
 

5. To adjust the setting for when the music/sound file stops, right-click on the sound icon 
and select Custom Animation. 
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6. In the Custom Animation dialog box, click on Effect Options. You will find several 
options here but one of the options is to have the music/sound file play for several 
slides by selecting After and setting the total number of slides the file should play 
through before turning off. 
 

 
Playing a CD During a Presentation 
 
You can also place a music CD into your CD-ROM drive and have it play during the PowerPoint 
slide show for a set duration you decide upon. The disadvantage to this approach is that you 
always have to remember to take the CD with you when you present the PowerPoint. To play a 
CD during a presentation: 
 

1. Insert the music CD into the CD-ROM drive. 
 

2. Navigate to the slide where you want the music to start playing. 
 

3. From the Insert menu, select Movies and Sounds > Play CD Audio Track… 
 

4. Set the Start: and End: Track numbers as well as the Time: boxes. (Note: To play only 
one track or part of a track, put the same number in both Track boxes.) In the Time: 
boxes, set the starting time (default start time is zero) and the ending time (default end 
time is the total number o minutes for the ending track). 
 

5. If you want the music to repeat, click to place a checkmark in the Loop Until Stopped 
checkbox. 
 

6. Click OK. PowerPoint will prompt you asking you if you want to play the music/sound 
Automatically or When Clicked. Select as you desire. Note: If you choose to start the 
music with a mouse click, the CD icon will appear on your slide even if you selected the 
Hide sound icon during slide show checkbox. However, you can minimize the sound 
icon image as you would a normal image and drag it to a discrete location (such as a 
button corner). 
 

 
 




