
Making Web Sites Accessible with  Dreamweaver MX
(PC)

Senate Bill 302 requires that all web sites be accessible to people with vision, hearing, and motor
impairments.  To the web developer, this means taking special precautions when creating web pages in
order to better facilitate assistive technologies such as screen readers (e.g., JAWS), alternative input
devices (e.g., Braille keyboards, voice recognition software, etc.), and text enlargement software (e.g.,
Zoom Text).  This document offers some suggestions of steps you can take when using Dreamweaver
MX that will assist you in following federal Section 508 standards and W3C guidelines.

Setting Dreamweaver MX Preferences for Web Accessibility
Dreamweaver MX allows you to set the preferences to remind you to follow Section 508 federal
accessibility standards as you insert images, tables, forms, and other media.

To Turn on Accessibility Preferences:

1. Go to the Edit menu and select Preferences (Command-U).
2. In the Category column of this dialog box, click on Accessibility.
3. Click all the checkmarks under Show Attributes when Inserting: (i.e., Form Objects, Frames,

Media, Images, Tables.
4. Make sure that Offscreen Rendering (Disable when using Screen Readers) is also selected.
5. Click OK.

Figure 1:  Accessibility Preferences in Dreamweaver MX (PC)
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Implementing Cal Poly Templates to Create Accessible Web Pages

The Cal Poly Web Authoring Resource Center (WARC) provides developers of Cal Poly Official Web sites
with the information and tools necessary to plan and build a site that meets basic requirements for
university identity, web accessibility, usability, and aesthetics. In addition, the WARC provides valuable
information on how best to maintain web sites for currency and efficiency.  Check out the WARC web site
by opening a browser (Internet Explorer or Netscape) and navigating to the following URL:
http://www.calpoly.edu/warc/

On the WARC website, you will find a section allowing you to download university templates:
http://www.calpoly.edu/warc/universityid/templates.html By using the university templates, you are
establishing your web pages as an "official" part of the Cal Poly University web site. The templates have
been designed to be consistent with and complimentary to the recent redesign of the Cal Poly home page
and its top-tier subsections (i.e., Students, Faculty & Staff, Prospective Students, etc.). The templates
conform to the university’s “Minimum Page Requirements” for web pages and were specifically designed
for easy navigation and eye-pleasing appearance after surveys and meetings with campus focus groups.
They have also been designed with usability and web accessibility in mind. You can easily "personalize"
them to reflect your department or group and each layout has been created to provide substantial "free"
space for extensive customization within the body of each template. We believe that it's important that Cal
Poly web pages reflect standards of quality and professionalism appropriate to showcase the university
as what it is -- one of the nation’s best -- and implementing the templates will assist you in this task.

Instructions on Downloading the Templates and Placing Them within Dreamweaver MX:

1. Go to http://www.calpoly.edu/warc/universityid/templates.html and read the web page to
learn more about using the university templates.

2. Click on the “Download Now” link at the top of this page.  This will take you to
http://www.calpoly.edu/warc/universityid/templates/download.html

3. Under the section labeled “HTML version download,” select the area that applies to your
operating system (PC) and click on the appropriate link (i.e., cp_template_v1.1.zip (PC) ) to
download the folder to the Desktop of your computer.

4. When the File Download dialog box appears (Figure 2), click on the Save button.

Figure 2:  File Download Dialog Box (PC)

5. When the Save As dialog box appears, save the file to your Desktop. Once the download is
complete, you will see a .zip file on your Desktop.  Use a utility such as Stuffit Expander, WinZip,
or Power Archiver to unzip the file. If you are using a Cal Poly license for the Power Archiver
utility, double-click on the file and when the Power Archiver new window pops up, choose Action
> Extract... In the "Extract to:" area, browse to the Desktop and click the Extract button.
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6.   You should now have a folder unzipped on your Desktop containing the cp_template.html and
instructions.html files, an images folder containing images for the template, and a Templates
folder containing an advanced Dreamweaver template called cp_dwtemplate.dwt.

7. Move the template images to the images folder that resides in your main (root) web site folder on
your computer.  Navigate to the downloaded template images folder and select everything (Ctrl-
A or Shift-Click each item) in this folder (including the header, footer, and menu_breadcrums
folders).  Right-click with your mouse and select Copy.

8. Open your images folder within your web site root folder.  Right-click in the images folder with
your mouse and select Paste to move the necessary template images to your root images folder.

9. Depending upon which template you have decided to use, move the cp_template.html file or the
cp_dwtemplate.dwt (from the Templates folder) into the main (root) folder of your web site on
your computer.

10. Right-click on the cp_template_v1.1.zip and select Delete to move the zipped folder (which
you’ll no longer need) to the Recycle Bin.

11. Read the instructions.html file and learn more about how to implement the templates by
dragging the instructions.html file into any browser window.

12. Use the cp_template.html or the cp_dwtemplate.dwt files to create more accessible web
pages.

Adding an Accessible Image
1. From the Insert menu, select Image (Control-Alt-I) and the Select Image Source dialog box will

appear (Figure 3).
2. Navigate to the image you desire to insert and click once on the image to see a preview of the

image at the right side of this dialog box.  If the image that shows in the Image Preview area is
the correct image, then click on the OK button to insert it on your web page.

Figure 3:  Select Image Source Dialog Box (PC)
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3. Since we set the preferences earlier to remind us to abide by web accessibility rules, the Image
Tag Accessibility Attributes dialog box will appear (Figure 4).  Where it says Alternate Text:,
type a short name to describe the image that the screen reader will read.  In the case of the
image shown in Figure 3 above, “Homer Simpson” would be a good alternate text tag to use.
Providing an alternate text tag will allow the screen reader to skip the image and continue reading
the page but also makes the user of the screen reader aware that there was an image of Homer
Simpson in that location on the web page.

Figure 4:  Image Tag Accessibility Attributes Dialog Box (PC)

Note:  If the image you inserted was primarily for page design (e.g., a header or footer image)
and not important for a screen reader to read to a blind or visually-impaired user, you should
ignore the Alternate Text: text box and simply click the OK button.  Then later you should select
the image on the page itself and then select the pop-up menu next to Alt and select <empty> in
the Properties Inspector.  This will place quotation marks next to the Alt tag in the code (e.g.,
alt=””), which will not be read by the screen reader.  When you run a Dreamweaver Accessibility
Report on a Cal Poly template (discussed later on in this tutorial) you will find many empty Alt
tags, which have been done this way.  Using this method will cause the screen reader to ignore
the image.

4. If the image on the page isn’t already selected, click on it to select it and continue with typical
image formatting (e.g., alignment, borders, links, etc.) in the Properties Inspector.

5. Go to File > Save As… and save your web page.

Adding an Accessible Table
Instructions for Adding a Web Accessible Table:

1. From the Insert menu, select Table (Ctrl-Alt-T) and the Insert Table dialog box will appear
(Figure 5).  Enter whatever values you desire in this dialog box and click on the OK button.

Figure 5:  Insert Table Dialog Box (PC)
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NOTE: Cell padding is the amount of space between the content of a layout cell and the cell wall
and Cell Spacing is the amount of space between each layout cell.

2. When the Accessibility Options for Tables dialog box appears (Figure 6), type a caption for the
table in the Caption: area.

3. From the Align Caption:  menu in this dialog box, select an alignment.
4. Type a  short summary for the table in the Summary:  area. This summary will be read by the

screen reader.
5. From Header:, select the manner in which this table should be read by the screen reader (Row,

Column, Both).

NOTE:  The Header attribute does not display in the browser window.  It is used primarily by
screen readers, assistant programs for the blind or visually impaired.  For example, if you choose
Header:  Row, scope tags will be applied to each cell of the top row of the table.  The scope tags
will make any information that you place in the cells of that top row act as identifiers for each of
the cells in their respective columns.  In this case, when we type “Food” in the top cell of the first
column, the remaining cells in that column will be prefaced verbally by the word “Food” in order to
indicate the content of those cells to a visually-impaired person. Header: Column will apply a
scope tag that acts as an identifier for the left column of the table. Header: Both will apply a
scope tag that acts as an identifier for both the main row and column cells.

Figure 6:  Accessibility Options for Tables Dialog Box (PC)

6. Click OK to apply these options and close the Accessibility Options for Tables dialog
box.

7. Select the table and continue with typical table formatting (e.g., alignment, borders,
fonts, colors, etc.) with the Properties Inspector.

8. Go to File > Save As… and save the web page.

Creating Accessible Forms with Dreamweaver MX
If you have set the Accessibility Preferences in Dreamweaver, you will be prompted to provide relevant
accessibility information. As you add each text box, you'll be asked to provide a label, an access key, and
the tab index. All of this prompted information makes the form significantly easier to navigate for people
with disabilities.

Adding Labels to Your Forms:

Labels identify the purpose of individual form objects, such as a text box, check box, or Submit button.
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When working with forms, users usually assume that the text to the left of the form object identifies its
purpose. In many cases, this is true; however, sometimes the visual layout requires labels to be located
to the right, above, or even below the form object. This can lead to considerable confusion for assistive
technology users.

Labels associate the label text with the form object through HTML. If the labels are identified in the HTML,
a screen reader will read the text label identified with the form object, regardless of where the label is
placed visually on the web page. While it's also important to pay attention to the visual layout of labels,
identifying labels within the HTML can make pages much easier for people to use with screen readers
and other assistive technologies.

1. When a form object is inserted on a page in Dreamweaver MX, the Input Tag Accessibility
Attributes dialog box appears (Figure 7):

Figure 7:  Input Tag Accessibility Attributes Dialog Box for Forms (PC)

2. In this example, a simple text box form object was added to the web page. The text label "First
Name" has been entered in the Label: text box.

3. Below the Label text box are three Style: options. The first two allow you to specify the HTML
coding technique used to mark up the label. Both represent standard HTML and will look the
same on the page.

4. The Wrap with Label Tag option places the HTML element <label> around the label and the
form object itself. This method is the simplest; however, it assumes that the label and the form
object will always be next to each other. This may not always be the case for each form element.

5. The Attach Label Tag Using 'for' Attribute option allows the label and form object to be
separated by table cells or placed above or below each other. This option requires a bit more
HTML code, but offers more flexibility than the first method.

Figure 8:  Text Field Labels (PC)
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6. When using the Attach Label Using 'for' Attribute option, remember that if the text label is
moved, the HTML label must be moved along with it. The easiest way to accomplish this is to
select the HTML label element in the status bar before dragging the text label elsewhere on the
page. This method will move the underlying HTML code along with the text.

Figure 9:  Label Tag in Dreamweaver MX Status Bar (PC)

7. The No Label Tag option allows you to omit a label. This option is also helpful when you plan to
add labels at a later time. However, Section 508 standards based on W3C guidelines require
labels to be identified within the HTML.

8. The Position: options in this dialog box allows you to decide whether to place the label before or
after the form object. You can choose either option, as long as your label placement is consistent
throughout the page.

Setting an Access Key:

Access keys allow users to quickly access individual form objects using a keyboard shortcut. This is
especially helpful on long forms that would otherwise require users to press the tab key numerous times
to access each text box. The inclusion of access keys is not required under Section 508 standards or
most policies based on W3C guidelines, but it can make a form much easier to navigate, especially for
people with mobility impairments.

1. In Figure 7, the Access Key: for the Label text box is set to “T”. To use this access key, users
would press Alt+T to move the cursor directly.

2. There are two issues to consider when adding access keys. First, you need to avoid standard key
combinations used in web browsers. For example, a natural choice for the Label text box might
have been Alt+F; however, Alt+F activates the File menu in most Microsoft Windows
applications. Instead, the letter 'T' was chosen from the end of the word “First”.

3. Also, keep in mind that once an access key is specified, users need to be notified. The most
common way to do this is to underline the letter used as the access key in the label of the form
object.

Setting a Tab Index:

A tab index specifies the order in which the tab key will move among the individual page elements. In
many browsers, the tab key will move among links, media objects, and form objects on the page. The
default tab order is determined by the order in which these objects appear in the HTML code. If this order
differs from the visual layout, a tab index might prove helpful. As with access keys, specifying a tab index
is not required under Section 508 or most policies based on W3C guidelines, but it can make a page
more navigable for disabled users when the layout is complex, or the default tab order is unusual.

However, once a tab order is specified, that order needs to be specified for all the form objects that
precede it. For example, a form object cannot be given the tab index value of 7 without previously
specifying objects 1 through 6. Furthermore, if there are more tabs then 7 and the tab order is not
specified beyond 7, then the browser will return to the default tab order from that point forward.
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Creating Accessible Media Objects with Dreamweaver MX
If you have the Media option selected in Accessibility Preferences you will see a Flash Accessibility
Attributes dialog box (Figure 10) whenever you insert any Flash media (e.g., Flash button) in
Dreamweaver MX.

Figure 10:  Flash Accessibility Attributes Dialog Box (PC)

Similar to the Input Tag Accessibility Attributes dialog box in Figure 7, the Flash Accessibility
Attributes dialog box (Figure 10) requests that you provide a Title:, Access Key:, and Tab Index for the
media object.  Please refer to the instructions in the section above, “Creating Accessible Forms with
Dreamweaver MX,” for more information.

Creating Accessible Frames with Dreamweaver MX
Cal Poly no longer supports the use of frames in web pages due to the accessibility problems that arise
from it.  However, if you are trying to retrofit an old Cal Poly web site to abide by accessibility guidelines,
then you may wish to contact ITS Technology and Learning Services for more information on how to
make these sites accessible.

Frames allow you to display multiple HTML documents on a single screen. Often, frames are used to
separate navigation windows from the content of a web page. Cal Poly recommends limiting the use of
frames  due to the following problems:

• Bookmarking framed pages presents problems because you can only bookmark the parent
frameset and default page instead of a desired child page (the bookmark will only reference the
parent frameset URL).

• Bookmarking a child page by itself (an "orphaned" page) may result in the loss of navigation and
other relevant  content that would be controlled by the parent frameset (the bookmark will only
reference the child page, outside of the frameset).

• Framed pages can present difficulties for printing. Framed pages that require horizontal scrolling
make printing (and using the page) more difficult.

• Search engines have a hard time indexing framed pages because they can't properly identify
what pages to include within the frameset (this doesn't apply to Google, which handles framed
pages appropriately)

• URLs typically, don't accurately reflect the page currently being displayed.

• Users lose the expected functionality of the back button, because you will go back within the
frame instead of the previous page from the frameset you are in.
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However, if you feel that it is necessary to use Frames, then make sure you include navigation with each
child page so that the page can be independently link to as a separate and usable page.

In addition, all framed pages (child pages) should include a some Javascript coding that forces the page
to load within the correct parent frameset page. The code to use for this can be found at:
http://www.webreference.com/js/column36/forcing.html

Also, make sure you use an appropriate <TITLE> for EVERY page in your framed Web site. All too often
the mistake is made that because a user doesn't see the Window Title of the child frame that it isn't
needed. This idea is incorrect and leads to pages not being titled correctly within a search engine.

1. If you have the Frames option selected in the Accessibility Preferences of Dreamweaver MX, you
will see the Frame Tag Accessibility Attribute dialog box whenever you insert a frame (Figure
11).

Figure 11:  Frame Tag Accessibility Attributes Dialog Box (PC)

2. Enter a Title: with a meaningful name for EACH frame.

Running an Accessibility Report in Dreamweaver MX
To validate a site for accessibility, start by opening a page from the site you wish to evaluate and make
sure that it has already been saved.

1. Select Site>Reports… and the Reports dialog box will appear (Figure 12).

Figure 12:  Reports Dialog Box (PC)
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2. If you wish to run a report on more than the current document, go to the pop-up menu next to
Report On: and select Entire Current Local Site or you may even specify individual folders for
evaluation.

3. Under the HTML Reports folder, select Accessibility and then click on the Report Settings…
button.

4. The Accessibility dialog box appears (Figure 13), which allows you to select the standards used
to evaluate a site (i.e., you may choose to validate based on Section 508 standards or the W3C
guidelines, or examine only a single set of elements, such as images.)  For example, if you would
like to only evaluate your site according to Section 508 standards, first select the ALL category
and click the Disable button.  This will turn ALL reporting off.  Then select the 508 accessibility
category and click the Enable button.  This will only activate rules pertaining to Section 508
standards.  Click the Save button to save your choices for future reports.

Figure 13: Accessibility Dialog Box (PC)

5. Click on the OK button and Dreamweaver MX will return to the Reports dialog box.  Click Run to
create a report, which will be displayed in the Results panel (Figure 14).

Figure 14:  Accessibility Report Results (PC)

6. Click on the Code and Design View button and then double-click on any line in the Results
Panel and it will highlight the place in the code where that problem occurs and also select the
property in the actual design view.  (Note:  The FAILED results in Figure 14 above are actually
valid since these images were part of the design of the web page, i.e.,  a footer image that we
wouldn’t want a screen reader to read out loud to the user)

The results are from both automatic and manual tests.  The automatic tests look for obvious
errors on the page, such as missing ALT tags.  The manual tests require you to review the
indicated content and consider such points, such as whether or not a long description is really
necessary for an image.  Failed automatic tests are indicated by a red X next to the item.
Required manual tests are indicated by a gray question mark (?) next to the item.
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Each item listed in the Results panel cites the relevant rule according to Section 508 standards
and W3C guidelines.  If you need more information about a particular standard, click the More
Info icon (Figure 15) in the Results panel to open the Reference panel.

Figure 15: More Info Button (PC)

The Reference panel provides explanations of the rules used and contains links to more detailed
information about Section 508 standards and W3C guidelines so you can make a better decision
about whether the error is valid.

After repairing a page, it’s wise to run the report again to verify that all problem issues have been
resolved.

7. If you want to save the report and examine it more later, you may click on the Save Report icon
(Figure 16) to the left of the Results panel.  This opens the Save As… dialog box, which will allow
you to name the report and save it as a .XML file to any location on your computer.

Figure 16:  Save Report Icon (PC)

8. If you wish to close the report window, click on the Close Report icon (Figure 17) in the top-right
corner of the Results panel and select Close Panel Group.

Figure 17:  Close Report Icon (PC)


